Last Comment Bug 813264 - Bug 809865 or Bug 810726 broke Skype click-to-call
: Bug 809865 or Bug 810726 broke Skype click-to-call
Status: RESOLVED FIXED
[qa:pending compatible addon]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: John Schoenick [:johns]
: Marcia Knous [:marcia - use ni]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 12:13 PST by Alex Keybl [:akeybl]
Modified: 2014-01-10 10:39 PST (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
unaffected
unaffected
18+
fixed


Attachments
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change (1.84 KB, patch)
2012-11-19 13:09 PST, John Schoenick [:johns]
benjamin: review+
Details | Diff | Splinter Review
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change (2.06 KB, patch)
2012-11-19 13:09 PST, John Schoenick [:johns]
benjamin: review+
Details | Diff | Splinter Review
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change. r=bsmedberg (2.19 KB, patch)
2012-11-19 13:20 PST, John Schoenick [:johns]
akeybl: approval‑mozilla‑release+
Details | Diff | Splinter Review
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change. r=bsmedberg (1.98 KB, patch)
2012-11-19 13:20 PST, John Schoenick [:johns]
akeybl: approval‑mozilla‑release+
Details | Diff | Splinter Review
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change (2.84 KB, patch)
2012-11-19 14:35 PST, John Schoenick [:johns]
akeybl: approval‑mozilla‑release+
lukasblakk+bugs: approval‑mozilla‑esr17+
john: checkin+
Details | Diff | Splinter Review
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change (3.17 KB, patch)
2012-11-19 14:36 PST, John Schoenick [:johns]
dbaron: review+
bzbarsky: feedback+
akeybl: approval‑mozilla‑release+
lukasblakk+bugs: approval‑mozilla‑esr17+
john: checkin+
Details | Diff | Splinter Review

Description Alex Keybl [:akeybl] 2012-11-19 12:13:42 PST
We've received email from Skype that 

"Rama Kurvakat who is a developer in Click-to-call team informed me today that there have been incompatible changes in the API in FF 17 beta 6. These changes in b6 which essentially invalidated all our testing effort on b5."
Comment 1 Alex Keybl [:akeybl] 2012-11-19 12:14:55 PST
In email, Benjamin got this down to one of two bugs:

https://hg.mozilla.org/releases/mozilla-beta/rev/b53dbef72a55
Bug 809865 - Disable inputmode. r=smaug a=lsblackk 

https://hg.mozilla.org/releases/mozilla-beta/rev/74d121044a74
Bug 810726: Backout 34d30fa24371 for infinite loop problems. [r=roc][a=lsblakk] 

We need to determine which of these two is the issue, come up with a patch, and consider re-spinning.
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-11-19 12:16:58 PST
Marcia is looking into this right now.
Comment 3 Benjamin Smedberg [:bsmedberg] 2012-11-19 13:03:14 PST
Johns is writing a patch to undo the two IID changes.
Comment 4 John Schoenick [:johns] 2012-11-19 13:09:25 PST
Created attachment 683284 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change
Comment 5 John Schoenick [:johns] 2012-11-19 13:09:41 PST
Created attachment 683285 [details] [diff] [review]
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change
Comment 6 Benjamin Smedberg [:bsmedberg] 2012-11-19 13:13:24 PST
Comment on attachment 683284 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change

Please add a brief comment referencing this bug explaining that this is for binary compat.
Comment 7 John Schoenick [:johns] 2012-11-19 13:20:28 PST
Created attachment 683289 [details] [diff] [review]
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change. r=bsmedberg
Comment 8 John Schoenick [:johns] 2012-11-19 13:20:57 PST
Created attachment 683290 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change. r=bsmedberg
Comment 9 Marcia Knous [:marcia - use ni] 2012-11-19 13:36:06 PST
We are testing in a VM now - I tested on different hardware and was not able to get it work even using FF 16.0.2,
Comment 10 juan becerra [:juanb] 2012-11-19 13:47:06 PST
The extension is not compatible with earlier versions (Fxbeta 4 or even beta 1).
Comment 11 juan becerra [:juanb] 2012-11-19 14:04:56 PST
(In reply to juan becerra [:juanb] from comment #10)
> The extension is not compatible with earlier versions (Fxbeta 4 or even beta
> 1).

Firefox 17b4 or b1.
Comment 12 Marcia Knous [:marcia - use ni] 2012-11-19 14:13:23 PST
I finally got it work in a Win XP VM in 16.0.2, but when trying to move to Firefox 17b5 it is not installing the extension.

As Juan notes, it isn't compatible when you install it in Firefox 17, so it makes it difficult to test the breakage they are citing between B5 and B6.
Comment 13 Alex Keybl [:akeybl] 2012-11-19 14:17:15 PST
(In reply to Marcia Knous [:marcia] from comment #12)
> I finally got it work in a Win XP VM in 16.0.2, but when trying to move to
> Firefox 17b5 it is not installing the extension.
> 
> As Juan notes, it isn't compatible when you install it in Firefox 17, so it
> makes it difficult to test the breakage they are citing between B5 and B6.

Thanks for testing. Even still, let's move forward with the respin since Skype won't push out a newer update for a week (thus making click-to-call non-functional on FF17) and we suspect that other binary add-ons may be affected (Yandex/Bandoo instability, for instance).
Comment 14 John Schoenick [:johns] 2012-11-19 14:35:45 PST
Created attachment 683311 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change
Comment 15 John Schoenick [:johns] 2012-11-19 14:36:10 PST
Created attachment 683312 [details] [diff] [review]
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change
Comment 16 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-11-19 14:45:38 PST
Comment on attachment 683312 [details] [diff] [review]
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change

r=dbaron (though I'd like bz to look at this as well when he gets back from dinner)

Given that bug 753517 is in Firefox 17, I'm not too worried about what these methods do.
Comment 17 Alex Keybl [:akeybl] 2012-11-19 15:00:27 PST
Comment on attachment 683312 [details] [diff] [review]
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change

[Triage Comment]
BZ won't be back for a few hours and we need to go to build to hit our Tuesday ship. Let's land on mozilla-release.
Comment 18 John Schoenick [:johns] 2012-11-19 15:33:45 PST
Comment on attachment 683311 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change

https://hg.mozilla.org/releases/mozilla-release/rev/8cdcad2877b9
https://hg.mozilla.org/releases/mozilla-release/rev/fe2f81698ee1
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-11-19 16:53:06 PST
Can someone theorize a list of add-ons for QA to test overnight?
Comment 20 Boris Zbarsky [:bz] (still a bit busy) 2012-11-19 18:07:20 PST
Comment on attachment 683312 [details] [diff] [review]
Restore MozColumnFill attribute to nsIDOMCSS2Properties as [noscript] to avoid IID change

Given that these properties are not declared pure virtual, this looks lovely!
Comment 21 Ted Mielczarek [:ted.mielczarek] 2012-11-20 07:23:24 PST
*** Bug 813568 has been marked as a duplicate of this bug. ***
Comment 22 Benjamin Smedberg [:bsmedberg] 2012-11-20 08:09:37 PST
I manually verified that inputelement.inputmode is undefined in 17.0build2.
Comment 23 George Haddad [:georgehdd] 2012-11-21 02:21:59 PST
(In reply to John Schoenick [:johns] from comment #18)
> Comment on attachment 683311 [details] [diff] [review]
> Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID
> change
> 
> https://hg.mozilla.org/releases/mozilla-release/rev/8cdcad2877b9
> https://hg.mozilla.org/releases/mozilla-release/rev/fe2f81698ee1

Why hasn't this been committed to ESR as well ?
Comment 24 George Haddad [:georgehdd] 2012-11-21 02:30:36 PST
(In reply to georgehdd from comment #23)
> (In reply to John Schoenick [:johns] from comment #18)
> > Comment on attachment 683311 [details] [diff] [review]
> > Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID
> > change
> > 
> > https://hg.mozilla.org/releases/mozilla-release/rev/8cdcad2877b9
> > https://hg.mozilla.org/releases/mozilla-release/rev/fe2f81698ee1
> 
> Why hasn't this been committed to ESR as well ?

or XUL SDK 17 ? (xulrunner-17.0.en-US.win32.sdk)
Comment 25 Alex Keybl [:akeybl] 2012-11-21 07:56:43 PST
(In reply to georgehdd from comment #23)
> (In reply to John Schoenick [:johns] from comment #18)
> > Comment on attachment 683311 [details] [diff] [review]
> > Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID
> > change
> > 
> > https://hg.mozilla.org/releases/mozilla-release/rev/8cdcad2877b9
> > https://hg.mozilla.org/releases/mozilla-release/rev/fe2f81698ee1
> 
> Why hasn't this been committed to ESR as well ?

We're going to be pushing this out as part of our next ESR release, 17.0.1esr. ESR17 usage will be very low this cycle, given the qualification period necessary by most major deployments. Please target FF17.0 mainline for the time being.
Comment 26 John Schoenick [:johns] 2012-11-21 11:53:43 PST
Comment on attachment 683311 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
Syncs IIDs with 17 release

User impact if declined:
Potential addon incompatibilities between 17 and 17ESR

Fix Landed on Version:
17

Risk to taking this patch (and alternatives if risky): 
Changes IIDs from what was on 17.0.0esr

String or UUID changes made by this patch: 
nsHTMLInputElement nsIDOMCSS2Properties
Comment 27 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-27 12:19:14 PST
Comment on attachment 683311 [details] [diff] [review]
Restore inputmode attribute to nsIDOMHTMLElement as [noscript] to avoid IID change

We're going to release a 17.0.1 (both normal and ESR) so please go ahead with landing this to the mozilla-esr17 branch asap.
Comment 29 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-27 22:53:39 PST
(In reply to John Schoenick [:johns] from comment #28)
> https://hg.mozilla.org/releases/mozilla-esr17/rev/30328bbb0901
> https://hg.mozilla.org/releases/mozilla-esr17/rev/016290a598e0

John, sorry for not mentioning it earlier - can you please land this to the ESR17 relbranch as well? There have been some security landings to mozilla-esr17 default that we are not intending to ship in respin.

GECKO170_2012111914_RELBRANCH
Comment 31 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-11-28 15:25:59 PST
Do we have a compatible version of Skype to test this with?
Comment 32 Manuela Muntean [Away] 2012-11-29 01:55:50 PST
The version of Skype Click-to-Call found here http://www.skype.com/intl/en/get-skype/on-your-computer/click-to-call/windows/ still doesn't work on Firefox 17.0.1 (Build ID: 20121128204232): the phone numbers aren't highlighted and can't be phoned.

It doesn't work on Chrome either.
Comment 33 Paul Silaghi, QA [:pauly] 2012-11-29 02:01:38 PST
(In reply to Manuela Muntean from comment #32)
> The version of Skype Click-to-Call found here
> http://www.skype.com/intl/en/get-skype/on-your-computer/click-to-call/
> windows/ still doesn't work on Firefox 17.0.1 (Build ID: 20121128204232):
> the phone numbers aren't highlighted and can't be phoned.
> 
> It doesn't work on Chrome either.

I cannot install Skype CTC at all on FF 17.0.1 on Win XP and Win 8.
Comment 34 Manuela Muntean [Away] 2012-11-29 02:03:40 PST
(In reply to Manuela Muntean from comment #32)
> The version of Skype Click-to-Call found here
> http://www.skype.com/intl/en/get-skype/on-your-computer/click-to-call/
> windows/ still doesn't work on Firefox 17.0.1 (Build ID: 20121128204232):
> the phone numbers aren't highlighted and can't be phoned.
> 
> It doesn't work on Chrome either.

I forgot to mention that I've tested on Windows 7 32-bit.
Comment 35 Ioana (away) 2012-11-29 02:08:16 PST
(In reply to Paul Silaghi [QA] from comment #33)
> I cannot install Skype CTC at all on FF 17.0.1 on Win XP and Win 8.

When starting the installer here [http://www.skype.com/intl/en/get-skype/on-your-computer/click-to-call/windows/], on the specified OSs, the installation process goes to the end without giving any errors. Yet, when starting Chrome and Firefox, the add-on shows up on Chrome but it doesn't appear anywhere for Firefox (not in Extensions folders, Add-ons Manager etc).
Comment 36 Alex Keybl [:akeybl] 2012-11-29 11:12:11 PST
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #31)
> Do we have a compatible version of Skype to test this with?

We have not received a newer version from Skype. As long as 17.0.1 is behaving no differently than 17.0, we'll be in good shape for when Skype does release their latest version.
Comment 37 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-11-29 11:14:12 PST
(In reply to Alex Keybl [:akeybl] from comment #36)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #31)
> > Do we have a compatible version of Skype to test this with?
> 
> We have not received a newer version from Skype. As long as 17.0.1 is
> behaving no differently than 17.0, we'll be in good shape for when Skype
> does release their latest version.

Okay, we've at least confirmed that. I'm dropping this from the 17.0.1 test plans to remove confusion. We'll still track for verification once we have a compatible version to test.
Comment 38 Tracy Walker [:tracy] 2014-01-10 10:39:21 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.