Closed Bug 810007 Opened 8 years ago Closed 7 years ago

Create an event with the start and end date/time being the same - block of time shows up on day in month view, but event not shown in agenda/week/day views

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, blocking-basecamp:-, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE3 (26jun)
blocking-b2g leo+
blocking-basecamp -
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: jsmith, Assigned: jlal)

References

Details

(Whiteboard: [interaction] [TD-46494][mozilla-triage])

Attachments

(1 file)

Build:

Device - Unagi

Hashes

  <project name="gaia" path="gaia" remote="b2g" revision="7ffd1c81db16bf0c6c3285a46259411d603109ca"/>
  <project name="releases-mozilla-aurora" path="gecko" remote="mozilla" revision="f059d3668a1acdeca0fac3c489205edcbe3c8779"/>

Steps:

1. Create an event with a start/end date/time equal to each other in the calendar app
2. View the event in the month/week/day/agenda views

Expected:

There should be a default amount space blocked off to show the event even if the the start and end date/times are the same, as seen in google calendar (also known as a theoretical min size for an event in each view).

Actual:

The event block is seen in the month view, but nothing is seen in the day, week, or agenda views. It's also impossible to delete the event created as a result if you get into this state.
Noming only due to the risk of getting into a state where you can't delete an event previously created.
blocking-basecamp: --- → ?
Gaia Triage : group decided  - ... , please renom if this becomes more critical.
blocking-basecamp: ? → -
bug 812644 should fix this issue
Priority: -- → P3
Whiteboard: [interaction]
Duplicate of this bug: 836021
Issue still occurring on an Unagi device running the following build:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/879324d41588
Gaia: e7e7c1a473b4069544f2dad779b1c9b1bab91663
Build: 20130327070202

User is still able to create a calendar event that starts and ends at the same time, leaving an event that can not be deleted, and can not be seen in any view other than the calendar on the month view.
Keywords: smoketest
This is not a smoketest blocker. Please only use the keyword for smoketest blockers.
Keywords: smoketest
Duplicate of this bug: 863541
Duplicate of this bug: 881592
Attachment #760739 - Flags: review?(gaye)
Attachment #760739 - Flags: review?(gaye) → review+
blocking-b2g: --- → leo+
Although this is a bug, I definitely do not think this is a blocker.
blocking-b2g: leo+ → leo?
Whiteboard: [interaction] → [interaction] [TD-46494]
Target Milestone: --- → 1.1 QE3 (24jun)
Mozilla triage recommends not blocking based upon this not have any user impact, but this is a Leo call.
Whiteboard: [interaction] [TD-46494] → [interaction] [TD-46494][mozilla-triage]
This issue is resolved by patch on Leo.
So TD-46494 status is changed Fixed.
blocking-b2g: leo? → leo+
in master: https://github.com/mozilla-b2g/gaia/commit/494aabedde6422ea225360f81b631366a7e897d8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: nobody → jlal
Uplifted 494aabedde6422ea225360f81b631366a7e897d8 to:
v1-train: 518823062d99c34bd9e4fd6e1267ed659155e13c
Keywords: verifyme
QA Contact: jsmith
1.1hd: 518823062d99c34bd9e4fd6e1267ed659155e13c
Verified on b2g18 by checking the STR in comment 0.
You need to log in before you can comment on or make changes to this bug.