Frequent b2g emulator reftest failures with "ERROR - Return code: 1" after ": Timeout waiting for marionette on port 'nnnnn'"

RESOLVED DUPLICATE of bug 809437

Status

defect
RESOLVED DUPLICATE of bug 809437
7 years ago
7 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=16899080&tree=Mozilla-Inbound
b2g_ics_armv7a_gecko_emulator mozilla-inbound opt test reftest-6 on 2012-11-09 09:03:52 PST for push 289d4cc01767
slave: talos-r3-fed-027

09:19:20     INFO -  pushing /system/b2g/components/binary.manifest (attempt 1 of 10)
09:19:20     INFO -  restarting B2G
09:19:20     INFO -  Traceback (most recent call last):
09:19:20     INFO -    File "runreftestb2g.py", line 563, in <module>
09:19:20     INFO -      sys.exit(main())
09:19:20     INFO -    File "runreftestb2g.py", line 483, in main
09:19:20     INFO -      marionette = Marionette(**kwargs)
09:19:20     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/marionette.py", line 148, in __init__
09:19:20     INFO -      self.emulator.install_gecko(self.gecko_path, self)
09:19:20     INFO -    File "/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/emulator.py", line 415, in install_gecko
09:19:20     INFO -      raise TimeoutException("Timeout waiting for marionette on port '%s'" % self.marionette_port)
09:19:20     INFO -  marionette.errors.TimeoutException/home/cltbld/talos-slave/test/build/venv/lib/python2.6/site-packages/marionette/errors.py:18: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
09:19:20     INFO -    return str(self.message)
09:19:20     INFO -  : Timeout waiting for marionette on port '43375'
09:19:20    ERROR - Return code: 1
09:19:20     INFO - TinderboxPrint: reftest<br/><em class="testfail">T-FAIL</em>
09:19:20  WARNING - # TBPL WARNING #
09:19:20  WARNING - The reftest suite: reftest-6 ran with return status: WARNING
09:19:20     INFO - #####
09:19:20     INFO - ##### B2GEmulatorTest summary:
09:19:20     INFO - #####
09:19:20  WARNING - # TBPL WARNING #
09:19:20  WARNING - The reftest suite: reftest-6 ran with return status: WARNING

Beyond the actual failure, that's not the most helpful logging, since out of all that the only part that's actually being pointed out to tbpl is the "09:19:20    ERROR - Return code: 1"
This is the same as bug 809437
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 809437
(Reporter)

Comment 6

7 years ago
You changed the summary of that just to mess with my head when I looked at what I'd missed, didn't you? :)
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.