Closed Bug 810440 Opened 8 years ago Closed 8 years ago

Camera - video recording - rotation angle dropped from function call

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: mikeh, Assigned: mikeh)

References

Details

Attachments

(1 file)

That will teach me to specify default values for parameters.

Also, it turns out the video recorder only supports positive rotation angles, so we need to enforce that as well.

logcat:
I/PRLog   (  963): 7005304[449156a0]: static int mozilla::GonkCameraHardware::GetSensorOrientation(uint32_t, uint32_t): aHwHandle = 1
I/PRLog   (  963): 7005304[449156a0]: setting video rotation to -180 degrees (mapped from -473399296)
V/GonkRecorder(  963): setParameters: video-param-rotation-angle-degrees=-180
V/GonkRecorder(  963): setParameter: key (video-param-rotation-angle-degrees) => value (-180)
I/PRLog   (  963): 7005304[449156a0]: mRecorder->setParameters(String8(buffer)) failed
I/PRLog   (  963): 7005304[449156a0]: [Child 963] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file /home/mikeh/dev/mozilla/btg014/gecko/dom/camera/GonkCameraControl.cpp, line 855
I/Gecko   (  963): [Child 963] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file /home/mikeh/dev/mozilla/btg014/gecko/dom/camera/GonkCameraControl.cpp, line 855
I/PRLog   (  963): 7005304[449156a0]: virtual nsresult mozilla::StartRecordingTask::Run():443 : result -2147024809
blocking-basecamp: --- → ?
Status: NEW → ASSIGNED
Also drop the default parameter values that allowed this bug to sneak through compilation and testing in the first place.

try-server push: https://tbpl.mozilla.org/?tree=Try&rev=5cac2685e04a
Attachment #680202 - Flags: review?(dale)
Comment on attachment 680202 [details] [diff] [review]
Add missing parameter to SetupRecording() call

Good for me
Attachment #680202 - Flags: review?(dale) → review+
Blocks: 809786
https://hg.mozilla.org/mozilla-central/rev/3b367d7be35f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
blocking-basecamp: ? → +
Blocking+ so needs landed on aurora
Keywords: checkin-needed
Whiteboard: needs-checkin-aurora
https://hg.mozilla.org/releases/mozilla-aurora/rev/0cbd88257eec

(FYI, I use bug queries to look for bb+ bugs needing Aurora uplift, so you don't need to specifically request it)
Keywords: checkin-needed
Whiteboard: needs-checkin-aurora
Duplicate of this bug: 809786
Duplicate of this bug: 806539
You need to log in before you can comment on or make changes to this bug.