Intermittent TEST-UNEXPECTED-FAIL | states/test_link.html | Test timed out followed by states/test_popup.xul | Doubled event { event type: document load complete, target: 'undefined' } in test with ID = 'link + 'link_traversed' clicked.'.

RESOLVED FIXED in mozilla19

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: philor, Assigned: surkov)

Tracking

({intermittent-failure, regression})

Trunk
mozilla19
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [test which aborts the suite])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #757774 +++

Starting on the push for bug 757774,

https://tbpl.mozilla.org/php/getParsedLog.php?id=16900968&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2012-11-09 10:18:22 PST for push c89140aad95a
slave: talos-r3-fed-020

9292 INFO TEST-INFO | chrome://mochitests/content/a11y/accessible/states/test_link.html | Invoke the 'link + 'link_traversed' clicked.' test { expected 'state change' event; expected 'document load complete' event;  }
9293 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_link.html | Test timed out.
(screenshot showing the "example.com" link with a focus outline)
9294 INFO TEST-END | chrome://mochitests/content/a11y/accessible/states/test_link.html | finished in 330334ms
9295 INFO TEST-START | chrome://mochitests/content/a11y/accessible/states/test_popup.xul
9296 INFO TEST-INFO | chrome://mochitests/content/a11y/accessible/states/test_popup.xul | must wait for load
9297 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_popup.xul | Doubled event { event type: document load complete, target:  'undefined' } in test with ID = 'link + 'link_traversed' clicked.'.
NOTE: child process received `Goodbye', closing down
INFO | automation.py | Application ran for: 0:08:05.975366
INFO | automation.py | Reading PID log: /tmp/tmpBuYEUBpidlog
==> process 2655 launched child process 2714
INFO | automation.py | Checking for orphan process with PID: 2714
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.

https://tbpl.mozilla.org/php/getParsedLog.php?id=16915172&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound opt test mochitest-other on 2012-11-09 18:09:09 PST for push 5dc1c0530b00
slave: talos-r3-fed64-027
https://hg.mozilla.org/mozilla-central/rev/4da6f3bf0cc3
Whiteboard: [orange][test which aborts the suite] → [orange][test which aborts the suite][leave open]
Posted patch patchSplinter Review
the problem is document load event may be fired before state changed event (see state_change event for defunct node):

registered: event type: state change, target:  'link_traversed'

registered async: event type: document load complete, target:  'undefined'

Event queue:
  invoke: link + 'link_traversed' clicked.
9304 INFO TEST-INFO | chrome://mochitests/content/a11y/accessible/states/test_link.html | Invoke the 'link + 'link_traversed' clicked.' test { expected 'state change' event; expected 'document load complete' event;  }

Event type: focus. Target: ['a@id="link_traversed" node', address: http://www.example.com/, role: link, name: 'example.com', address: [xpconnect wrapped nsIAccessible]]

Event type: reorder. Target: [' no node info ', role: app root, name: 'Firefox', address: [xpconnect wrapped nsIAccessible]]

Event type: hide. Target: ['input node', address: [object HTMLInputElement], role: entry, name: 'Yahoo', address: [xpconnect wrapped nsIAccessible]]

Event type: show. Target: ['input node', address: [object HTMLInputElement], role: entry, name: 'Search using Yahoo', address: [xpconnect wrapped nsIAccessible]]

Event type: reorder. Target: ['textbox node', address: [object XULElement], role: autocomplete, name: 'Search using Yahoo', address: [xpconnect wrapped nsIAccessible]]

Event type: document load complete. Target: ['document node', address: [object XrayWrapper [object HTMLDocument]], role: document, name: 'about:blank', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

*****
EQ matched: document load complete
*****

Event type: state change. Target: [' no node info 'defunct, address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

Event type: focus. Target: ['a@id="link_traversed" node', address: http://www.example.com/, role: link, name: 'example.com', address: [xpconnect wrapped nsIAccessible]]

Event type: state change. Target: ['toolbarbutton@id="urlbar-reload-button" node', address: [object XULElement], role: pushbutton, name: 'Location', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

Event type: state change. Target: ['toolbarbutton@id="urlbar-reload-button" node', address: [object XULElement], role: pushbutton, name: 'Location', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1
9305 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_link.html | Test timed out.
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #680511 - Flags: review?(trev.saunders)
Attachment #680511 - Flags: review?(trev.saunders) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/e73ee9780c4d
Whiteboard: [orange][test which aborts the suite][leave open] → [orange][test which aborts the suite]
https://hg.mozilla.org/mozilla-central/rev/e73ee9780c4d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Whiteboard: [orange][test which aborts the suite] → [test which aborts the suite]
Blocks: 815646
You need to log in before you can comment on or make changes to this bug.