Intermittent accessible/states/test_link.html | Doubled event { event type: document load complete, target: 'undefined' } in test with ID = 'link + 'link_traversed' clicked.'.

RESOLVED FIXED in Firefox 19

Status

()

Core
Disability Access APIs
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: emorley, Assigned: surkov)

Tracking

({intermittent-failure})

Trunk
mozilla20
All
Linux
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 fixed, firefox20 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #810554 +++
Similar to bug 810554 except without the initial timeout.

Rev3 Fedora 12 mozilla-inbound opt test mochitest-other on 2012-11-26 10:13:13 PST for push 7e97c5392d81

slave: talos-r3-fed-005

https://tbpl.mozilla.org/php/getParsedLog.php?id=17345817&tree=Mozilla-Inbound

{
9332 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_link.html | Doubled event { event type: document load complete, target:  'undefined' } in test with ID = 'link + 'link_traversed' clicked.'.
}

With more context:
{
9313 INFO TEST-START | chrome://mochitests/content/a11y/accessible/states/test_link.html
9314 INFO TEST-INFO | chrome://mochitests/content/a11y/accessible/states/test_link.html | must wait for load
9315 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_href' !
9316 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for ['null node', address: [object Text], role: text leaf, name: 'link', address: [xpconnect wrapped nsIAccessible]]!
9317 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_click' !
9318 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_mousedown' !
9319 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_mouseup' !
9320 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_arialink' !
9321 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_ariabutton' !
9322 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | state bits should not be present in ID  'link_ariabutton' !
9323 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_notlink' !
9324 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | state bits should not be present in ID  'link_notlink' !
9325 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for  'link_traversed' !
9326 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | state bits should not be present in ID  'link_traversed' !
9327 INFO TEST-INFO | chrome://mochitests/content/a11y/accessible/states/test_link.html | Invoke the 'link + 'link_traversed' clicked.' test { expected 'state change' event; expected 'document load complete' event;  }
9328 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | Wrong extra state bit of the statechange event.
9329 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | Wrong state of the statechange event.
9330 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | Wrong state of statechange event state
9331 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | wrong state bits for ['a@id="link_traversed" node', address: http://www.example.com/, role: link, name: 'example.com', address: [xpconnect wrapped nsIAccessible]]!
9332 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/states/test_link.html | Doubled event { event type: document load complete, target:  'undefined' } in test with ID = 'link + 'link_traversed' clicked.'.
9333 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | test with ID = 'link + 'link_traversed' clicked.' failed. No state change event.
9334 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/states/test_link.html | test with ID = 'link + 'link_traversed' clicked.' failed. No document load complete event.
9335 INFO TEST-END | chrome://mochitests/content/a11y/accessible/states/test_link.html | finished in 811ms
}
(Assignee)

Comment 1

5 years ago
enable logging: http://hg.mozilla.org/integration/mozilla-inbound/rev/0c242b9fcb54
Hi, I backed this out for crashes in Moth tests.  Sorry.

https://hg.mozilla.org/integration/mozilla-inbound/rev/126d3e10e2d4
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 5

5 years ago
Created attachment 686479 [details] [diff] [review]
enable logging

it seems that was a recent change that documents having no presshell get document loading notificaitons (or something was changed in UI).
Attachment #686479 - Flags: review?(trev.saunders)
Attachment #686479 - Flags: review?(trev.saunders) → review+

Updated

5 years ago
Duplicate of this bug: 816368
(Assignee)

Comment 7

5 years ago
enable logging (phase 2) http://hg.mozilla.org/integration/mozilla-inbound/rev/5061278bcf35
Whiteboard: [leave open]
(Reporter)

Comment 8

5 years ago
https://hg.mozilla.org/mozilla-central/rev/5061278bcf35
Comment hidden (Treeherder Robot)
(Assignee)

Comment 10

4 years ago
about:blank document gets created before example.com document (a document open in new window on link click). From screen reader user point of view that could mean extra noise in temporary documents announcement. As far as I know we don't have any idea whether about:blank document is temporary or persistent one to filter the case.

Jamie, is flashing about:blank documents loadings (document complete load event + busy state change event) a problem for AT?
Flags: needinfo?(jamie)

Comment 11

4 years ago
If it ever gets focus, it will create extraneous "noise". If it doesn't get focus, it shouldn't.
Flags: needinfo?(jamie)
(Assignee)

Comment 12

4 years ago
Created attachment 687666 [details] [diff] [review]
fix the test

It doesn't seem (per Jamie's comment) we have a real problem here so let's fix the test.
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #687666 - Flags: review?(trev.saunders)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 687666 [details] [diff] [review]
fix the test

any idea why this isn't an issue in other tests?
(Assignee)

Comment 16

4 years ago
(In reply to Trevor Saunders (:tbsaunde) from comment #15)
> Comment on attachment 687666 [details] [diff] [review]
> fix the test
> 
> any idea why this isn't an issue in other tests?

You mean tests that listen document_load_complete events? Maybe we should wait longer.
Comment hidden (Treeherder Robot)
(Assignee)

Comment 18

4 years ago
ping?
(In reply to alexander :surkov from comment #16)
> (In reply to Trevor Saunders (:tbsaunde) from comment #15)
> > Comment on attachment 687666 [details] [diff] [review]
> > fix the test
> > 
> > any idea why this isn't an issue in other tests?
> 
> You mean tests that listen document_load_complete events? Maybe we should

yes

> wait longer.

not sure what you mean by that.
(Assignee)

Comment 20

4 years ago
(In reply to Trevor Saunders (:tbsaunde) from comment #19)

> > wait longer.
> 
> not sure what you mean by that.

I meant this failure doesn't happen very often so maybe we will see other tests failing one day.

I don't really see how they are different so that they shouldn't fail.
Comment hidden (Treeherder Robot)
(In reply to alexander :surkov from comment #20)
> (In reply to Trevor Saunders (:tbsaunde) from comment #19)
> 
> > > wait longer.
> > 
> > not sure what you mean by that.
> 
> I meant this failure doesn't happen very often so maybe we will see other
> tests failing one day.
> 
> I don't really see how they are different so that they shouldn't fail.

ok, not sure I like it but I guess we can live with it.
Attachment #687666 - Flags: review?(trev.saunders) → review+
Comment hidden (Treeherder Robot)
(Assignee)

Comment 24

4 years ago
(In reply to Trevor Saunders (:tbsaunde) from comment #22)
> (In reply to alexander :surkov from comment #20)
> > (In reply to Trevor Saunders (:tbsaunde) from comment #19)
> > 
> > > > wait longer.
> > > 
> > > not sure what you mean by that.
> > 
> > I meant this failure doesn't happen very often so maybe we will see other
> > tests failing one day.
> > 
> > I don't really see how they are different so that they shouldn't fail.
> 
> ok, not sure I like it but I guess we can live with it.

at least you should try :) I really don't see alternatives, due to specialties of document loadings we can get a temporary document created, that's what log shows us, per Jamie's comment it shouldn't affect on them so there's no practical reason to fix this behavior and thus we need to fix a failing test. Also there's no practical reason to fix other similar tests because they may fail since we don't have known failures. Fixing a test is not ideal solution but it seems a practical one.
(Assignee)

Comment 25

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f586bd6769d3
Whiteboard: [leave open]
Comment hidden (Treeherder Robot)
(Reporter)

Comment 27

4 years ago
https://hg.mozilla.org/mozilla-central/rev/f586bd6769d3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/releases/mozilla-aurora/rev/ecb1b9236b54
https://hg.mozilla.org/releases/mozilla-aurora/rev/c77a793b8449
status-firefox19: --- → fixed
status-firefox20: --- → fixed
You need to log in before you can comment on or make changes to this bug.