Wrong tab rendering when "layout.css.devPixelsPerPx" property is more than "1.0"

RESOLVED WORKSFORME

Status

Thunderbird
Theme
--
major
RESOLVED WORKSFORME
5 years ago
10 months ago

People

(Reporter: Nickolay Mazurkin, Unassigned)

Tracking

16 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 680333 [details]
Ugly tabs when layout.css.devPixelsPerPx > 1

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121025210744

Steps to reproduce:

I got a new laptop with 15'' 1980x1080 screen. 

Menus and dialogs in Thunderbird are displayed well but plain-text message text looks too small so I decided to set "layout.css.devPixelsPerPx" property to "1.3" as I did in Firefox. Everything looks perfect now except tabs which seem to have some style problems.

Environment:
- Xubuntu 12.04
- XFCE 4.8
- resolution 120 dpi is set for the system


Actual results:

Everything works fine but upper tabs looks very ugly (llook at the tabs on the screenshot attached)


Expected results:

Tabs should be rendered correctly
(Reporter)

Comment 1

5 years ago
I have fixed this annoying bug with Stylish the following style chunk

.tab-background {
  background: transparent!important;
  margin: 0px !important;
}

.tab-background[selected=true] {
  background: -moz-Dialog!important;
} 

.tabmail-tab:not([selected]):not(:hover) +
.tabmail-tab:not([selected]):not(:hover)::before {
  background: transparent!important;
}
Severity: normal → major
Component: Toolbars and Tabs → Theme
I can't see this issue on Ubuntu, KDE or Mint with force DPI to fonts. Maybe this setting isn't the same as yours. I also don't know why the tab isn't filled properly, the svg has set fill=-moz-Dialog. Maybe this is a svg bug.

Andreas, please can you check if you see this bug on your system?
Flags: needinfo?(bugs)
I can't see this issue on Ubuntu, KDE or Mint with force DPI to fonts. Maybe this setting isn't the same as yours. I also don't know why the tab isn't filled properly, the svg has set fill=-moz-Dialog. Maybe this is a svg bug.

Andreas, please can you check if you see this bug on your system?
How do I force the DPI? gconf?
Flags: needinfo?(bugs)
I also set layout.css.devPixelsPerPx to 1.3 (and a bunch of other values), and I'm unable reproduce this too.
This is under GNOME 3.4 on Fedora 17
(Reporter)

Comment 6

5 years ago
Some details, home these would help

- 15'' screen laptop
- 1920x1080 resolution
- xubuntu 12.04 (XFCE 4.8)
- system DPI is set to 120
- Radiance system theme
- Humanity icon theme
- Ubuntu 10 as a main system font
- Thunderbird 16.0.2+build1-0ubuntu0.12.04.1 from standard repository
- Clean run (rm -rf ~/.thunderbird)
- After I set layout.css.devPixelsPerPx=1.3 these unformed tabs appear and this is the only problem I see

Comment 7

11 months ago
paenglab, does comment 6 help?
Flags: needinfo?(richard.marti)
I can't reproduce this on Linux.

TB 16 had the first implementation of the Australis tabs. Now they are differently implemented and this shouldn't happen now.

Nickolay, can you reproduce this issue with actual TB?
Flags: needinfo?(richard.marti) → needinfo?(mazurkin)
(Reporter)

Comment 9

11 months ago
TB 45.5.1 - tabs are OK on Xubuntu with layout.css.devPixelsPerPx=1.3, no additional patching is required
Thank you, Nickolay.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME

Updated

10 months ago
Flags: needinfo?(mazurkin)
You need to log in before you can comment on or make changes to this bug.