Closed Bug 810597 Opened 7 years ago Closed 7 years ago

crash in GetPrintCanvasElementsInFrame

Categories

(Core :: Layout, defect, critical)

19 Branch
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- unaffected
firefox19 - verified

People

(Reporter: scoobidiver, Assigned: peterv)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

It first showed up in 19.0a1/20121110. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=90cea19e27e2&tochange=a47525b93528

Signature 	nsHTMLCanvasElement::FromContent(nsIContent*) More Reports Search
UUID	31ca9451-2def-4780-8f35-2bcaa2121110
Date Processed	2012-11-10 16:14:14
Uptime	70
Last Crash	1.2 minutes before submission
Install Age	6.1 minutes since version was first installed.
Install Time	2012-11-10 16:08:03
Product	Firefox
Version	19.0a1
Build ID	20121110030714
Release Channel	nightly
OS	Windows NT
OS Version	6.2.9200
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xc
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0126, AdapterSubsysID: 21db17aa, AdapterDriverVersion: 9.17.10.2867
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x0126
Total Virtual Memory	4294836224
Available Virtual Memory	3714801664
System Memory Use Percentage	48
Available Page File	5743583232
Available Physical Memory	4340219904
Accessibility	Active

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsHTMLCanvasElement::FromContent 	obj-firefox/dist/include/nsHTMLCanvasElement.h:49
1 	xul.dll 	GetPrintCanvasElementsInFrame 	layout/generic/nsSimplePageSequence.cpp:523
2 	xul.dll 	nsSimplePageSequenceFrame::PrePrintNextPage 	layout/generic/nsSimplePageSequence.cpp:623
3 	xul.dll 	nsPrintEngine::PrePrintPage 	layout/printing/nsPrintEngine.cpp:2746
4 	xul.dll 	nsPagePrintTimer::Notify 	layout/printing/nsPagePrintTimer.cpp:137
5 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:485
6 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:565
7 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:627
8 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
9 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:208
10 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:182
11 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
12 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:229
13 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:290
14 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3822
15 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3889
16 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:4083
17 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:105

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsHTMLCanvasElement%3A%3AFromContent%28nsIContent*%29
https://crash-stats.mozilla.com/report/list?signature=GetPrintCanvasElementsInFrame%28nsIFrame*%2C+nsTArray%3CnsRefPtr%3CnsHTMLCanvasElement%3E%2C+nsTArrayDefaultAllocator%3E*%29
There are about 20 crashes an hour making it #2 top crasher in today's build.
Seeing this crash reliably trying to print a message from GMail.
Alice, can you reproduce this by chance?
Printing about:home in any printer is enough to make Nightly crash.
Sounds like easy fodder for a crashtest too then.
Flags: in-testsuite?
Duplicate of this bug: 810723
Whiteboard: [native-crash]
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c39596b46863
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121109072233
Crash:
http://hg.mozilla.org/mozilla-central/rev/a47525b93528
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121110030714
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c39596b46863&tochange=a47525b93528


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/843a3db9c045
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121109114832
Crash:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ee3ee9e659bd
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121109120731
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=843a3db9c045&tochange=ee3ee9e659bd

Suspected: bug 804991
Blocks: 804991
Looks like that should be FromContentOrNull?
Assignee: nobody → peterv
Starting to see this in SUMO forums as well, https://support.mozilla.org/en-US/questions/941721
Attached patch v1Splinter Review
Attachment #680723 - Flags: review?(bzbarsky)
Please can this get a crashtest?
Comment on attachment 680723 [details] [diff] [review]
v1

r=me
Attachment #680723 - Flags: review?(bzbarsky) → review+
I went ahead and pushed this to inbound so I can merge it to m-c tonight in time for tomorrow's nightly. Sorry if I'm stepping on your toes, Peter.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ea36ae3e9f0
https://hg.mozilla.org/mozilla-central/rev/5ea36ae3e9f0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Duplicate of this bug: 811373
I can confirm that printing is again working for me in Nightly, build 1912.11.13.  The printing problem I had reported (in dup bug #810723) can no longer be reproduced with today's Nightly.  :-)
Duplicate of this bug: 812429
Verified the crash for the 2012-11-10 Nightly by trying to print from about:home and message in Gmail as suggested
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121110030714

No crashes using the same scenario for Firefox 19.0 beta 3.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130123083802
You need to log in before you can comment on or make changes to this bug.