Tiles get marked as invalid/outside content area, causing automatic zoom into remaining content and unable to pan until zoomed out

RESOLVED DUPLICATE of bug 810933

Status

()

--
major
RESOLVED DUPLICATE of bug 810933
6 years ago
6 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 680368 [details]
screenshot invalid areas

Firefox for Android nightly 20121110, Android 4.1.2 (stock), Google Nexus S

Starting with the 20121108 nightly, the following behavior can be observed:

Some areas (tiles?) are not shown and regarded as "no content area" (see screenshot). If you tap onto a remaining, valid content area, the app will automatically zoom in and panning won't allow you to move the invalid area into the viewport, sometimes trapping you in the current viewport. Zooming out usually repaints the area and allows to pan again.
Often this behavior kicks in during panning, causing surprise moves and zoom of the content in view.

Example pages where I observed this behavior:
1. https://addons.mozilla.org (see screenshot)
2. http://www.dwdl.de/full/ zoom in onto the newsbox on the right and keep some space left of it in the view. Then try to move left.
2. http://m.rockstargames.com/newswire

Seems like the more resources needed, the more likely this can be observed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810933
You need to log in before you can comment on or make changes to this bug.