If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Regression: Unable to initially scroll pages

VERIFIED FIXED in Firefox 19

Status

()

Firefox for Android
Toolbar
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: kats)

Tracking

({regression, reproducible, smoketest})

Trunk
Firefox 19
ARM
Android
regression, reproducible, smoketest
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/pushgloghtml?fromchange=eb636c95b1c0&tochange=d6a48ba051bc

--
Nightly (11/12)
Samsung Galaxy Nexus (Android 4.1.2)
Samsung Galaxy Note II (Android 4.1.1)
(Reporter)

Comment 1

5 years ago
I am using http://www.arstechnica.com as a test-case here; when the document is done - attempt to scroll down.
(Reporter)

Comment 2

5 years ago
Work-around that works for me; triggering a rotation that triggers a redraw 'restores' functionality
(Reporter)

Updated

5 years ago
Duplicate of this bug: 810291
(Reporter)

Comment 4

5 years ago
Bug 809199
Blocks: 809199
(Reporter)

Comment 5

5 years ago
Comment 0 should be http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=eb636c95b1c0&tochange=d6a48ba051bc
(Reporter)

Updated

5 years ago
Assignee: nobody → bugmail.mozilla
Created attachment 680805 [details] [diff] [review]
Patch

The arguments passed to the ImmutableViewportMetrics constructor are different than those passed to the old ViewportMetrics constructor, and my patch from bug 809199 that updated the JNI code failed to update it.
Attachment #680805 - Flags: review?
Attachment #680805 - Flags: review? → review?(chrislord.net)
Blocks: 810693

Comment 7

5 years ago
Comment on attachment 680805 [details] [diff] [review]
Patch

Review of attachment 680805 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #680805 - Flags: review?(chrislord.net) → review+
Blocks: 810171
https://hg.mozilla.org/integration/mozilla-inbound/rev/cd854e9fe7c1
(Reporter)

Updated

5 years ago
Status: NEW → ASSIGNED
Duplicate of this bug: 810942
https://hg.mozilla.org/mozilla-central/rev/cd854e9fe7c1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
No longer blocks: 810693
Duplicate of this bug: 810693

Updated

5 years ago
status-firefox19: affected → ---
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
status-firefox19: --- → verified
Duplicate of this bug: 810599
You need to log in before you can comment on or make changes to this bug.