Regression: GeckoLayerClient aborts on panning, content dies

RESOLVED DUPLICATE of bug 810933

Status

()

Firefox for Android
Toolbar
--
major
RESOLVED DUPLICATE of bug 810933
5 years ago
4 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({regression, reproducible, smoketest})

Trunk
ARM
Android
regression, reproducible, smoketest
Points:
---

Firefox Tracking Flags

(firefox19 affected)

Details

(URL)

(Reporter)

Description

5 years ago
Pan through an article such as any Wikipedia article, and eventually GeckoLayerClient will abort and content will die; see video: http://www.youtube.com/watch?v=e_Py7Y7afsQ

D/GeckoLayerClient( 1398): Aborting update due to more relevant display-port in event queue
I/Gecko   ( 6719): WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x8053000C: file ../../../../content/base/src/nsGenericElement.cpp, line 2500

--
Nightly (11/12)
Samsung Galaxy Nexus (Android 4.1.2)
Samsung Galaxy Note II (Android 4.1.1)
(Reporter)

Comment 1

5 years ago
Also seeing plenty of:

I/Gecko   ( 6719): ###!!! ASSERTION: Should be in construction phase: 'InConstruction()', file ../../../gfx/layers/basic/BasicLayerManager.cpp, line 531
This is also a regression from Bug 809199. Maybe the patch in Bug 810933 fixes this also.
Blocks: 809199
Keywords: regressionwindow-wanted

Comment 3

5 years ago
(In reply to Jim Chen [:jchen :nchen] from comment #2)
> This is also a regression from Bug 809199. Maybe the patch in Bug 810933
> fixes this also.

Very likely - we can't make the right abort decisions without correct metrics. The assertions mentioned in comment #1 don't sound good though, this sounds like we're calling EndTransaction without a corresponding BeginTransaction, or after AbortTransaction.
(Reporter)

Comment 4

5 years ago
So far from a limited amount of testing on inbound this morning, I think the patch in bug 810933 fixed this.
Duping to 810933 then. Feel free to un-dupe if it happens again.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810933
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.