Can't script Real Player Plugin

VERIFIED DUPLICATE of bug 59935

Status

()

Core
Plug-ins
--
major
VERIFIED DUPLICATE of bug 59935
17 years ago
16 years ago

People

(Reporter: spongman, Assigned: av (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001050515

Calling methods on an embedded Real Player Control from javascript doesn't work.

Reproducible: Always
Steps to Reproduce:
1) Open the URL provided.
2) Click the 'Play URL' button.

It should call a method on the plugin to start playing.

Actual Results:  All you get is a script error:

  Error: document.javaPlug1.SetSource is not a function
  Source File: 
http://agassiz.prognet.com/devzone/tools/demos/java/rajavascript.html
Line: 17



Expected Results:  As in IE and NS4.7x, the media should start playing, no 
script error.


Real Player 8 Basic (6.0.9.584)
Real plugin 6.0.8.1024 (nppl3260.dll)


RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)

    File name: c:\Program 
Files\Netscape\Communicator\Program\Plugins\nppl3260.dll
RealPlayer(tm) LiveConnect-Enabled Plug-In

Mime Type Description Suffixes Enabled
audio/x-pn-realaudio-plugin RealPlayer(tm) as Plug-in (*.rpm) rpm Yes

Comment 1

17 years ago
You need an XPConnect enabled plugin.  4x plugins are not scriptable in Mozilla
based browsers.
(Reporter)

Comment 2

17 years ago
is there an XPCOM version of the real plugin available?

Comment 3

17 years ago
There are various bug reports about one - but don't know if it's public yet.
Duplicate of "Javascript function calls to plugin do not work (in Real Player)"

*** This bug has been marked as a duplicate of 59935 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.