Javascript function calls to plugin do not work (in Real Player)

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: ecohen, Assigned: serhunt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It seems that function calls like 'doPlay(), doStop(), doPause()' which are
Javascript calls to RealPlayer plugin provoke the following error :
"xxx.doPlay is not a function"
whatever xxx is between :
- document.pluginInstanceName
- document.getElementById('pluginInstanceID')

My plugin is embedded to the Web page using <EMBED> tag.

With netscape navigator, I use the following :
- document.pluginInstanceName.doPlay() to start playing a video.

We will be using Mozilla on Linux-based platforms as an interface for
interactive TV applications.
So far we've developed our interface on Windows NT platforms.

Q:
Is there another JavaScript syntax I can use ?
Is this problem related to Real Player plugin (I use V.8) ?
Have you tried using the <OBJECT> tag
(http://www.w3.org/TR/html4/struct/objects.html#h-13.3)?

It may not help, but it's worth a try...

Comment 2

18 years ago
Browser, not engine. Reassigning to Plugins component -
Assignee: rogerl → av
Component: Javascript Engine → Plug-ins
QA Contact: pschwartau → shrir

Comment 3

18 years ago
LiveConnect (4x style of plugin scripting) is not supported in mozilla.  You'll 
have to wait for Real to ship an XPCOM plugin.

Comment 4

18 years ago
Huh? I thought we had just fixed that bug.

Comment 5

18 years ago
Lack of support for LiveConnect (as opposed to xpconnect) scripting of plugins
was an architectural decision made long ago and won't be 'fixed'.
(Reporter)

Comment 6

18 years ago
To sum up :
- I had a try with <OBJECT> tag but Mozilla simply ignores it.
- If I want to use plugin functions, I have to wait for the XPCOM component to 
be released (if it doesn't exist yet).
- La balle est dans le camp de Real Networks (only Real can solve this problem)

Is that it ?

Comment 7

18 years ago
Pretty much.  I know that they are working on an update - it might already be 
included in the n6 download.

Comment 8

18 years ago
Reporter is this still a problem in the latest nightlies?

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 9

18 years ago
This is a Real problem not ours. When they get there act together I am sure we
will have many more bugs. Until then there is nothing we can do. Marking INVALID.

Comment 10

18 years ago
*** Bug 62275 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
verif
Status: RESOLVED → VERIFIED
*** Bug 90035 has been marked as a duplicate of this bug. ***
*** Bug 81136 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
This bug is not invalid. Scripting isn't working in Real on Linux. This bug has
moved. See:
http://bugzilla.mozilla.org/show_bug.cgi?id=111773
You need to log in before you can comment on or make changes to this bug.