Bookmark properties window is not an alert, so it shouldn't try to look like one

RESOLVED DUPLICATE of bug 14211

Status

P4
normal
RESOLVED DUPLICATE of bug 14211
18 years ago
14 years ago

People

(Reporter: mpt, Assigned: bugs)

Tracking

Trunk
mozilla1.2alpha
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2001051504, Mac OS 9.1

To reproduce:
*   Open the properties window for a bookmark.

What you should see:
*   A properties window.

What you actually see:
*   Something that thinks it's an alert.

As a properties window, the bookmark properties window should not have any of 
the following:
-   icons on each tab (it should have a bookmark icon on the `General' tab, but
    that's for another bug);
-   annoying text explaining to you things like what a bookmark is (by the
    time you get to this window, you know quite enough about that sort of thing
    already);
-   `OK' or `Cancel' buttons (changes should be saved when the window is
    closed).

Comment 1

18 years ago
Taking each of your points in turn:

- Agreed.
- I think the text is useful. A user could come across the window while
exploring Mozilla (by activating the context menu on a Personal Toolbar item,
for example). The text helps to explain what the dialogue is for.
- On Windows, properties windows do have 'OK' and 'Cancel' buttons, so a fix for
this should be Mac only.
general polish/correctness
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.2

Comment 3

18 years ago
I don't get this.  Things like this are by nature dialogs on Windows, with 
buttons and all.  So is this meant to be mac-only?

Comment 4

18 years ago
yes. this is from mpt's mac bug spree.  on macos alerts and other windows 
should look very differently and we don't currently behave correctly.

Comment 5

18 years ago
nav triage team:

low priority, marking nsbeta1+, p4, and mozilla0.9.3
Keywords: nsbeta1+
Priority: -- → P4
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 6

18 years ago
nav triage team:

Not a 0.9.3 stopper, marking mozilla1.0
Target Milestone: mozilla0.9.3 → mozilla1.0
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 8

17 years ago
not a mozilla1.0 stopper, marking mozilla1.2
Target Milestone: mozilla1.0 → mozilla1.2

Comment 9

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 14211 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.