Closed Bug 812456 Opened 10 years ago Closed 10 years ago

Extension block request: DataMngr

Categories

(Toolkit :: Blocklist Policy Requests, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox17 - ---
firefox18 - ---

People

(Reporter: scoobidiver, Assigned: jorgev)

References

Details

(Whiteboard: [extension])

Attachments

(2 files)

Extension name: DataMngr
Extension UUID: {1FD91A9C-410C-4090-BBCC-55D3450EF433}
Extension versions to block: All
Applications, versions, and platforms affected: Windows
Block severity: (hard/soft)

Homepage, AMO listing, other references and contact info: http://www.bandoo.com/

Reasons: Top crasher in 17.0 Beta (see bug 812307) and malware (see http://forums.spybot.info/showthread.php?t=62634)
I'm concerned about the possibility of add-on interactions of toolbars with DataMngr causing new instability (per your https://bugzilla.mozilla.org/show_bug.cgi?id=812307#c5).  

In Jorge's absence, Fligtar - what are our options for targeting only the Beta channel with this blocklist before rolling out to production for all?
Assignee: nobody → fligtar
(it would be great to still get something staged for QA to test regardless, in case we decide we need to move forward with this post-release)
QA Contact: virgil.dicu
Attempting to reproduce in 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 RC
Build ID: 20121116115405

I have installed the software from jzip.com wich installs datamgr 1.0 (disabled in FF 17.0), from bandoo.com and imesh.com as suggested in comments of bug 812307. 

I have Bandoo for Firefox 5.1, Incredibar-Games EN 10.12.40.15, searchqu 10.12.40.15 installed but whit all this, there was no crash by my side on Windows 7 x64. 

I sent some emails, played some games from this toolbars, visited some sites, visited facebook, but still no crash.

I have no DataMngrHlpFF17.dll installed in my computer.

Is there anything else I could help here?
Blocked on staging: https://addons-dev.allizom.org/en-US/firefox/blocked/i215

Please test with the block and let me know if it's effective in addressing the crash.
Assignee: fligtar → jorge
(In reply to Jorge Villalobos [:jorgev] from comment #4)
> Blocked on staging: https://addons-dev.allizom.org/en-US/firefox/blocked/i215
> 
> Please test with the block and let me know if it's effective in addressing
> the crash.

QA has as of yet been unable to reproduce this crash. I think that's been mostly due to the fact that we have yet to find a binary which installs DataMngrHlpFF17.dll on our systems. 

At the very least I can confirm that pinging staging adds the following to my blocklist.xml:
<emItem blockID="i215" id="{1FD91A9C-410C-4090-BBCC-55D3450EF433}">
  <versionRange minVersion="0" maxVersion="*" severity="1"></versionRange>
</emItem>
Blocks: 813945
Blocks: 814007
I just started with a fresh profile testing Firefox 16.0.2 and here are my results:

1. Install Firefox 16.0.2 and use a fresh profile
2. Set up the blocklist about:config entries (but haven't pinged for the blocklist that is staged)
3. Install the jzip toolbar and other stuff
4. View the addons manager
5. Below is the list of extensions - you can see that datamngr.dll is disabled even before I pinged for the staged blocklist.

I was able to get that dll compat when I ran the same profile in FF 16.0.2 that I was using for testing FF 17.

Extensions

        AOL Toolbar
        5.74.1.8935
        true
        {7affbfae-c4e2-4915-8c0f-00fa3ec610a1}

        Bandoo for Firefox
        5.1
        true
        ffox@bandoo.com

        DailyBibleGuide
        2.71.0.60936
        true
        2vffxtbr@DailyBibleGuide.com

        Searchqu Toolbar
        4.1.0.01
        true
        {99079a25-328f-4bd4-be04-00955acaa0a7}

        DataMngr
        1.0
        false
        {1FD91A9C-410C-4090-BBCC-55D3450EF433}

        FilmFanatic
        2.71.0.60974
        false
        paffxtbr@FilmFanatic.com

        Microsoft .NET Framework Assistant
        0.0.0
        false
        {20a82645-c095-46ed-80e3-08825760534b}
Thanks Marcia, that's an interesting result.

Scoobidiver/KaiRo - do you know if disabled add-ons still show up in crash reports?
(In reply to Alex Keybl [:akeybl] from comment #7)
> Scoobidiver/KaiRo - do you know if disabled add-ons still show up in crash
> reports?

No, from all I know, only active add-ons are being transmitted.
Bandoo believes they have a fix that they're pushing out currently. This will likely be wontfix as of next week.
Do we know if Bandoo pushed a fix out that corrects this well enough?
(In reply to Tyler Downer [:Tyler] from comment #10)
> Do we know if Bandoo pushed a fix out that corrects this well enough?
Bug 812307 is #4 top browser crasher in 17.0.1, bug 813945 is #87 and bug 814007 is #17. The overall is #4 top browser crasher in 17.0.1 with about 12k crashes/week.
On November 22 before the fix, bug 812307 was #4 top browser crasher in 17.0, bug 813945 was #6 and bug 814007 was #9. The overall was #3 top browser crasher in 17.0.
So despite their assertion, they haven't pushed a fix.
Actually, from what I remember, I had seen it going down after they said they pushed a fix, but it came back in the last week or so.
As they do not do proper versioning of their libraries, we can't tell if the crashes that happen now are with a version before or after where they said they fixed the issue.

We probably need to contact them again.
can we do a blocker to this as you cant remove it full from firefox or nightly
Alex, was it you who contacted Bandoo before? Should we ping them again about the crash problems?
Attached image data manager 1
their is no way to remove this addon after you click disable
Attached image data manager 2
That happens with all globally-installed add-ons. It's unrelated with Data Manager.
(In reply to Jorge Villalobos [:jorgev] from comment #14)
> Alex, was it you who contacted Bandoo before? Should we ping them again
> about the crash problems?

I'm sending email to Michael at iMesh now.
(In reply to Alex Keybl [:akeybl] from comment #18)
> (In reply to Jorge Villalobos [:jorgev] from comment #14)
> > Alex, was it you who contacted Bandoo before? Should we ping them again
> > about the crash problems?
> 
> I'm sending email to Michael at iMesh now.

Alex, did you ever receive a response from them?
Flags: needinfo?(akeybl)
Since the bugs being blocked by this are not high priority, the conversations with the developers have been productive, and we haven't been able to adequately assess the impact of blocking this extension, we're desisting on this block for the time being.
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(akeybl)
Resolution: --- → WONTFIX
Jorgev can you try contacting the developers of this addon
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.