Closed Bug 812512 Opened 10 years ago Closed 10 years ago

merge day changes for bug 773120 - remove 10.5 (Leopard) jobs from all of our code

Categories

(Release Engineering :: General, defect, P2)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Assigned: armenzg)

References

Details

Attachments

(4 files, 6 obsolete files)

Attached patch remove leopard completely (obsolete) — Splinter Review
Two versions after 17 we can drop the esr10 code and we can then disable the Leopard tests completely.
Blocks: 812509
Depends on: 773120
Attachment #682463 - Attachment is patch: true
Assignee: nobody → armenzg
Priority: -- → P2
Attached patch leopard changes (obsolete) — Splinter Review
Attachment #682463 - Attachment is obsolete: true
Attachment #715502 - Flags: review?(coop)
Attachment #682464 - Attachment is obsolete: true
Attachment #715503 - Flags: review?(coop)
Duplicate of this bug: 809311
Comment on attachment 715502 [details] [diff] [review]
leopard changes

Review of attachment 715502 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla/project_branches.py
@@ +333,5 @@
>          },
>      },
>      'pine': {},
>      'gaia-master': {
> +        'poll_repo': 'integration/gaia-central',

Is this part of a different patch?
Attachment #715502 - Flags: review?(coop) → review+
Attachment #715503 - Flags: review?(coop) → review+
(In reply to Chris Cooper [:coop] from comment #5)
> Comment on attachment 715502 [details] [diff] [review]
> leopard changes
> 
> Review of attachment 715502 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mozilla/project_branches.py
> @@ +333,5 @@
> >          },
> >      },
> >      'pine': {},
> >      'gaia-master': {
> > +        'poll_repo': 'integration/gaia-central',
> 
> Is this part of a different patch?

Yes. I noticed later.
Attached patch remove leopard (tools) (obsolete) — Splinter Review
Attachment #715532 - Flags: review?(coop)
Attachment #715534 - Flags: review?(coop)
Comment on attachment 715532 [details] [diff] [review]
remove leopard (tools)

Review of attachment 715532 [details] [diff] [review]:
-----------------------------------------------------------------

::: buildfarm/mobile/setup_foopy.py
@@ +10,5 @@
>  toolsdir = "/builds/tools"
>  path_to_bmm_host = "/builds/bmm.hostname.txt"
>  path_to_manage_buildslave = "/builds/manage_buildslave.sh"
>  # cltbld's uid and gid
> +const_uid=getpwnam('cltbld')[2]

Is there a reason to not preserve the spacing now? Isn't the spacing pep8?
Attachment #715532 - Flags: review?(coop) → review+
Comment on attachment 715532 [details] [diff] [review]
remove leopard (tools)

Review of attachment 715532 [details] [diff] [review]:
-----------------------------------------------------------------

r- JUST for the inclusion of these two files in this patch

::: buildfarm/mobile/manage_buildslave.sh
@@ -1,1 @@
>  #!/bin/bash

The changes to this file will break clientproxy-less foopies, and sure don't belong lumped in this patch, I suspect it was an oversight.

::: buildfarm/mobile/setup_foopy.py
@@ -6,1 @@
>  

I can't imagine these changes belong in this patch either
Attachment #715532 - Flags: review-
Comment on attachment 715534 [details] [diff] [review]
remove leopard (puppet)

Review of attachment 715534 [details] [diff] [review]:
-----------------------------------------------------------------

r+, assuming you don't remove talos-r3-snow-NN from test_runslave.py.

::: modules/buildslave/files/test_runslave.py
@@ -180,5 @@
>          't-r3-w764-NN' : 'c:\\talos-slave',
>          'talos-r3-fed-NN' : '/home/cltbld/talos-slave',
>          'talos-r3-fed64-NN' : '/home/cltbld/talos-slave',
> -        'talos-r3-leopard-NN' : '/Users/cltbld/talos-slave',
> -        'talos-r3-snow-NN' : '/Users/cltbld/talos-slave',

Need to keep Snow Leopard.
Attachment #715534 - Flags: review?(coop) → review+
Attached patch remove leopard (tools) (obsolete) — Splinter Review
I'm sorry about the mess. Dealing with both esr10 removal and leopard removal has been making mess things up.
Attachment #715532 - Attachment is obsolete: true
Attachment #715607 - Flags: review?(coop)
Attachment #715607 - Attachment is obsolete: true
Attachment #715607 - Flags: review?(coop)
Attachment #715609 - Flags: review?(coop)
Attachment #715609 - Flags: review?(coop) → review+
Attachment #715609 - Flags: checked-in+
Attached patch wip - leopard changes (obsolete) — Splinter Review
I decided to wait on esr10 to land first before I finish this up (as the patches were crossing over each other).

This patch passes test-masters.sh but I have to confirm that we only remove what we need and nothing more.
Attachment #715502 - Attachment is obsolete: true
Attachment #715609 - Flags: checked-in+ → checked-in-
This is a no-op change after landing the removal of esr10.
Attachment #715648 - Attachment is obsolete: true
Attachment #715782 - Flags: review?(aki)
Comment on attachment 715782 [details] [diff] [review]
remove leopard completely (buildbot-configs)

Looks like we can also kill mozilla2/macosx/ .
Attachment #715782 - Flags: review?(aki) → review+
Attachment #715503 - Flags: checked-in+
Attachment #715534 - Flags: checked-in+
Live in production.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.