Closed Bug 812681 Opened 7 years ago Closed 6 years ago

android webdev wants to be able to receive audio call via PeerConnection

Categories

(Core :: WebRTC, defect, P2)

ARM
Android
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: dmose, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [WebRTC], [blocking-webrtc-][android-webrtc+][qa-])

This is basically just the ability to receive an audio call.  There are tests for analogous video functionality in bug 796890, but they are not yet completed.  It might be a reasonable strategy to fork that patch into an audio call version, make it pass on desktop, and then make it pass on Android.  At one point, there were enough crashes on desktop that development of those tests stalled out.  They might or might not be fixed now.  Coordination with Whimboo is suggested before deciding whether or not to pursue the above strategy.

My suspicion is that there will be enough to do to make this scenario work that we may not want to do it all in this bug, but that it may make sense to spin out some dependent bugs.  As an example, my understanding from Ethan is that there's some signaling code that's going to need to be written on Android.  I don't have a sense for what else, if anything, is hiding under the covers.
To get the sense of what real-life code that does this and more might look like, reviewing <https://github.com/anantn/socialapi-demo> may be helpful, though the code was put together very quickly.
Summary: android webdev wants to be able to play received audio call via PeerConnection → android webdev wants to be able to receive audio call via PeerConnection
Is this about a test to write or what? It's not clear for me right now. But if that's the case it's a dupe of bug 796892.
Whiteboard: [DUPEME]
Agreed, dup
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796892
No, this isn't a dup. This is bug written in user story format from a developer's perspective for android. If you look at the similar bug to this in bug 812650 - what Dan is talking about basically is the following:

- Figure out what code changes and bug fixes need to be made in order to make an audio call in WebRTC on Android

It's possible this could be a metabug with multiple parts, but that's my understanding after reading the other bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [DUPEME]
Priority: -- → P2
Whiteboard: [WebRTC], [blocking-webrtc-]
Whiteboard: [WebRTC], [blocking-webrtc-] → [WebRTC], [blocking-webrtc-][android-webrtc+]
gcp - isn't this already fixed? Or is there more work to be done here?
Flags: needinfo?(gpascutto)
Yep, and we already have a different meta bug for Android WebRTC (bug 750010).
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Flags: needinfo?(gpascutto)
Resolution: --- → FIXED
Whiteboard: [WebRTC], [blocking-webrtc-][android-webrtc+] → [WebRTC], [blocking-webrtc-][android-webrtc+][qa-]
You need to log in before you can comment on or make changes to this bug.