Account creation disabled for "improper connections"

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Antti Laine, Unassigned)

Tracking

16 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 682730 [details]
Screenshot of the warning dialog

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121027181922

Steps to reproduce:

1) Add Mail Account
2) Enter manual configuration
3) Click "Re-Test" button, settings are found
4) Click "Done" button
5) Receive huge red warning dialog


Actual results:

Dialog has the following information (btw. warning dialog texts should be copyable, which it is not):

"Warning!

Thunderbird can allow you to get to your mail using the provided configurations. However, you should contanct your administrator or email provider regarding these improper configurations. See the Thunderbird FAQ for more information."
 
Account creating is blocked, as "Done" button is disabled.

The dialog gives zero information about the reason it popped up, and the information that is given is incorrect in at least three ways:

1) It is marked as a "warning", although it clearly is an error, as futher steps can not be taken.
2) It says Thunderbird can allow using given settings, but there is nothing else to do than to click the "Change Settings" button.
3) There is no mention of "improper settings" in Thunderbird FAQs in https://support.mozillamessaging.com/en-US/kb/thunderbird-faq nor http://kb.mozillazine.org/Thunderbird_:_FAQs


Expected results:

1) Sensible reason for the warning dialog should have been given
2) If the settings can not be used, the text should not claim otherwise, or
3) If the settings can in fact be used, "Done" button should not be disabled
4) Incorrect reference to FAQ should not have been given
Normally, there is a check box to acknowledge the warnings. Can you monitor the error console (under the tools menu) whilst attempting to set up the account and see if any errors or possibly relevant warnings show up?
(Reporter)

Comment 2

5 years ago
These three errors appear when creating a new account, after filling in name and email address, and clicking continue:

Timestamp: 19.11.2012 12.28.07
Error: 
Source File: resource:///modules/errUtils.js
Line: 91
---------------------------------------------
Timestamp: 19.11.2012 12.28.08
Error: Not Found
Source File: resource:///modules/errUtils.js
Line: 91
---------------------------------------------
Timestamp: 19.11.2012 12.28.09
Error: Not Found
Source File: resource:///modules/errUtils.js
Line: 91

No new errors appear after I click the "Done" button and the warning dialog is shown.

The only reference to modules/errUtils.js I can find in my system is in /usr/lib/thunderbird/removed-files.

Comment 3

5 years ago
Just run into this issue today.
The most curious thing is, with the "improper settings", clicking on "Done" gives you this confusing warning/error dialog... But clicking on "Advanced config" in the same "Mail Account Setup" dialog -- gets the account created instantly, silently and without any complaints.

Ahem, at least it didn't lie that it "can allow you to get to your mail using the provided configurations."

Comment 4

4 years ago
I ran into this issue today.

Thunderbird 17.0.7, OS X 10.8.4.

Also, the email config is really, really, REALLY annoyingly complicated. It wastes time trying to lookup in Mozilla's ISP database and trying "common hostnames", before permitting manual setup, which then fails with this exact issue.

As for others, using "Advanced config" circumvents the huge red warning dialog.

Why does this bug remain unconfirmed?

See also:

https://getsatisfaction.com/mozilla_messaging/topics/wont_create_account_even_though_it_says_it_will

http://superuser.com/questions/565141/warning-thunderbird-can-allow-you-to-get-to-your-mail-using-the-provided-config

Comment 5

4 years ago
(In reply to Jan Ingvoldstad from comment #4)
> I ran into this issue today.
> 
> Thunderbird 17.0.7, OS X 10.8.4.

and 17.0.7 on 10.8.5, fwiw

In my case, I had the "SMTP server" set to be an existing (working, thank you very much) server.  Changed it to ".example.com" (for mail at example.com) and filled in my settings -- IDENTICAL to the existing server -- then I was allowed through, no longer 'improper'.

Same symptoms, no checkbox, no Done button, no further info.

Comment 6

4 years ago
This is still a problem with Thunderbird 24.1.0. Depending on what it is TB does not like, there may, indeed be a check-box as Mark mentions in Comment 1. But not always.

Not only is the bug annoying, but the very premise -- that "mother knows best" -- is outright infuriating.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

4 years ago
This issue still exists in Thunderbird 24.5.0. It is simply impossible to create an account. No clue as to what TB thinks is wrong, nothing. No checkbox to tick, no way to get around this. It is utterly ridiculous that you can not set up a mail account the way you want it to.
(Reporter)

Comment 8

4 years ago
(In reply to Freddy from comment #7)
> It is simply impossible to create an account. No clue as to what TB thinks is wrong, nothing. No
> checkbox to tick, no way to get around this.

There is a way around it: as mentioned in comment 3, clicking Advanced config creates the account without any complaints.

Comment 9

3 years ago
This is still an issue. I am stuck and I am using 24.6.0
Still an issue with version 31.1.0. Workaround: Instead of clicking "Done", click "Advanced config", then "OK".

Comment 11

3 years ago
Hm, why are we ever hiding the checkox - http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountcreation/emailWizard.js#1764

Comment 12

3 years ago
Can anybody say what options for connection security and password encryption you filled in to get this dialog? The dialog seems bogus as it does not report what the problem is. It should show either weak security for incoming or outgoing server. If there is no such problem it should not even show.

Comment 13

3 years ago
(In reply to Magnus Melin from comment #11)
> Hm, why are we ever hiding the checkox -
> http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/
> accountcreation/emailWizard.js#1764

The problem is the code stores whether we acknowledged the checkbox for the incoming or the outgoing server. But in the picture there is no server mentioned. So we shouldn't have even shown the dialog.

Comment 14

3 years ago
I could imagine the dialog could happen if one of the assert()s in needed() throws, then needed() does not return anything falsy and the dialog is shown even if there is no security error in the servers. But I now tested it and that does not happen.

Comment 15

3 years ago
Have you tried to use an existing SMTP server instead of creating a new one?

Comment 16

3 years ago
Likely dupe of bug 1048791.

Comment 17

3 years ago
Confirmed. Clicking Done without testing gives a red "warning" window that doesn't have any checkboxes, and the next button is disabled. Going back and clicking "re-test" also fails, but does not state any reason why. That button also disables advanced config button (why??).
(I was using a private server with imap tcp993/ssl)

Changing anything and returning it back enables the advanced config button, which then happily accepts the settings as it should. Error console shows only one error, which complains that the server uses an "invalid" certificate, which is due to unknown issuer (missing chain info). Another reason is that the server was reached via alias name that is not mentioned in the certificate. When connecting, I finally get a popup asking if I actually still want to trust the server. In this case I won't, but this should be viewable right away.

In general, I also find these kind of "smart" features frightening as I feel that this is sending my password and user info to all-around the place while figuring out what server works. (And that's why I put garbage data into those fields before clicking next.) 
Please enable advanced config button next to 'get new account'. All kinds of automatic setups should be ignorable.

Comment 18

3 years ago
I am still experiencing this issue as of Thurderbird 31.5.0

If you would like additional debugging details, I would be happy to provide them.

Comment 19

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 3.0?

Updated

3 years ago
blocking-b2g: 3.0? → ---

Comment 20

3 years ago
Well, nobody responded to my comment 15, so we have no idea what is causing this bug. So it cannot be fixed. Unless of course it is the same as bug 1048791. But even there nobody confirmed the fix. So the fix is currently only in TB38, which will be released soon.

Comment 21

3 years ago
please test the beta from http://www.mozilla.org/en-US/thunderbird/channel/ and give us feedback.
Flags: needinfo?(srl)
Flags: needinfo?(jani+mozilla-bugzilla)
Flags: needinfo?(antti.a.laine)

Comment 22

3 years ago
The beta (v38.0) fixed the issue for me

Comment 23

2 years ago
(In reply to jared from comment #22)
> The beta (v38.0) fixed the issue for me

Jared, big thank you
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(srl)
Flags: needinfo?(jani+mozilla-bugzilla)
Flags: needinfo?(antti.a.laine)
Resolution: --- → WORKSFORME
See Also: → bug 1048791
You need to log in before you can comment on or make changes to this bug.