Context menu, awesome bar, and search bar popup content occasionally or persistently not rendered

VERIFIED FIXED in Firefox 18

Status

()

Core
Layout: View Rendering
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: IU, Assigned: roc)

Tracking

({regression})

Trunk
mozilla20
x86_64
Windows 8
regression
Points:
---

Firefox Tracking Flags

(firefox18+ fixed, firefox19+ verified, firefox20 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Specifically on Windows 8 (not affecting Firefox on any other Windows platform), Firefox context menu, awesome bar, and search bar popup content will occasionally or persistently not render when certain extensions are present.  All that becomes visible is a transparent rectangle with only the shadow visible.

In the case of the awesome bar and search bar, when this issue occurs, continuing to type more text will eventually cause it to render properly.

One set of such issues was triggered by Inspect Context extension.  After disabling that extension, I found yet another trigger -- which is the subject of the following consistently reproducible STR:

1. Unzip Firefox 32-bit m-c nightly build
2. Launch Firefox with a new profile
3. Install the "Add-ons Manager Context Menu" extension and restart: https://addons.mozilla.org/en-US/firefox/addon/am-context/?src=api
4. Open Add-ons Manager and switch to the Extension context
5. Right-click the listed extension.  Notice that the context menu appears and is visible
6. Right-click the extension again.  Notice that the context menu is now transparent, with only the shadow visible.  All subsequent right-clicks in this context will yield the same result.
7. If you close the Add-ons Manager and reopen, notice that the context menu works again, possibly persistently.
8. Try this a few times and you will find sometimes it works properly all the time or breaks.

To observe this issue that Inspect Context triggers, affecting all other context menus, use the following STR:

9. Install Inspect Context extension: https://addons.mozilla.org/en-US/firefox/addon/inspect-context/?src=ss
10. Close Add-ons Manager and right-click any tab on the tab bar.
11. Right-click again.  If the bug has not been triggered, right-click the page
12. If the bug has still not been triggered, perform these following steps:
a) Open a new tab 
b) Close the tab
c) Right-click the currently open tab and choose "Undo Close Tab"
13. Try your right-clicks again.  By now, the bug should have been triggered
14. At this time too, if you type in the awesome bar, click away, to make the drop-down disappear and then go back to typing, you will also notice the bug.
(Reporter)

Updated

5 years ago
Blocks: 539356
Why did you mark this blocking DLBI? Did DLBI regress this?
tracking-firefox18: --- → ?
(Reporter)

Comment 2

5 years ago
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #1)
> Why did you mark this blocking DLBI? Did DLBI regress this?

Looks like you're right.  Sorry.  Looks more likely like bug 610713 regressed it.

range is: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ecd4c4304219&tochange=9738e5a0190a

Jim: is this a regression from bug 610713?
No longer blocks: 539356
Keywords: regression
Here's a patch that attempts to disable the 610713 fix/workaround on Windows 8. Try this build here to see if it fixes your problem:
https://tbpl.mozilla.org/?tree=Try&rev=39fdd078fe09
(Reporter)

Comment 4

5 years ago
Backing that out fixed the issue.
(Reporter)

Comment 5

5 years ago
I mean disabling it.
Created attachment 683887 [details] [diff] [review]
fix
Assignee: nobody → roc
Attachment #683887 - Flags: review?(jmathies)
Hopefully we don't need the COMPOSITED workaround on Windows 8.
tracking-firefox19: --- → ?

Updated

5 years ago
tracking-firefox18: ? → +
tracking-firefox19: ? → +

Updated

5 years ago
Attachment #683887 - Flags: review?(jmathies) → review+

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/676bf833f816
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
(Reporter)

Comment 11

5 years ago
Verified fixed in today's nightly build; cset c72d38e7a212

Thanks
Status: RESOLVED → VERIFIED
Can we get this uplifted to mozilla-beta?
Comment on attachment 683887 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 610713
User impact if declined: very poor usability on Windows 8
Testing completed (on m-c, etc.): a week on m-c
Risk to taking this patch (and alternatives if risky): low risk. At worst, bug 610713 will reappear for some Windows 8 users. This bug is worse than that.
String or UUID changes made by this patch: none
Attachment #683887 - Flags: approval-mozilla-beta?
Attachment #683887 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #683887 - Flags: approval-mozilla-beta?
Attachment #683887 - Flags: approval-mozilla-beta+
Attachment #683887 - Flags: approval-mozilla-aurora?
Attachment #683887 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/cfc0672e3ad0

This didn't apply cleanly to beta due to bug 802456 not fully landing on it. I wasn't sure how to proceed, so I left it alone for now.
status-firefox18: --- → affected
status-firefox19: --- → fixed
status-firefox20: --- → fixed
Created attachment 689868 [details] [diff] [review]
beta patch

Straight-forward change to apply to beta.
Attachment #689868 - Flags: review?(roc)
Attachment #689868 - Flags: review?(jmathies)

Updated

5 years ago
Attachment #689868 - Flags: review?(jmathies) → review+
Attachment #689868 - Flags: review?(roc)

Comment 16

5 years ago
(In reply to Timothy Nikkel (:tn) from comment #15)
> Created attachment 689868 [details] [diff] [review]
> beta patch
> 
> Straight-forward change to apply to beta.

We're just a bit more restrictive than what we have on mc right, so this seems ok with me.
Comment on attachment 689868 [details] [diff] [review]
beta patch

[Approval Request Comment]
See comment 13, this is just the same patch fixed up to apply to beta.
Attachment #689868 - Flags: approval-mozilla-beta?
Comment on attachment 689868 [details] [diff] [review]
beta patch

This is just an unbitrotting, so the original approval still applies.
Attachment #689868 - Flags: approval-mozilla-beta?
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

Verified as fixed in Firefox 19 beta 5 folowing STR from comment 0(buildID: 20130206083616), latest Nightly (buildID: 20130212031120), latest Aurora (buildID: 20130211042016)
status-firefox19: fixed → verified
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed in Firefox 20 beta 6 (buildID: 20130320062118) folowing STR from comment 0.
status-firefox20: fixed → verified
You need to log in before you can comment on or make changes to this bug.