Closed Bug 813205 Opened 9 years ago Closed 6 years ago

crash in F21225463

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

x86
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1156903

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-445a57e6-6e06-4d62-9081-e1d4a2121119 .
============================================================= 

Seen while looking at crash stats. Happens across all versions and no bug associated with it, so filing. Link to crashes in last week: https://crash-stats.mozilla.com/report/list?signature=F21225463__________________________________________________________________________________________________________

Heavier concentration of Win 7 users are hitting this crash across all versions. Comments mention Gmail and Facebook.

Frame 	Module 	Signature 	Source
0 	NPSWF32_11_5_502_110.dll 	F21225463_______________________________________________________________________ 	F2050211588____________________________________________________________________________________________:1234
1 	NPSWF32_11_5_502_110.dll 	F1717497556_____________________________________________________________________ 	F979678132_____________________________________________________________________:1162
2 	NPSWF32_11_5_502_110.dll 	F1470906166_________________________________________________ 	F2050211588____________________________________________________________________________________________:1022
3 	NPSWF32_11_5_502_110.dll 	F_1513036030________________________________________ 	F2133178019_____________________________________________________________________________:46
4 	NPSWF32_11_5_502_110.dll 	F_424569316__________________________________________________ 	F1313573471__________________________________________________________________________________:199
5 	NPSWF32_11_5_502_110.dll 	F1607135317_____________________________________________________________________ 	F_334370096____________________________________________________________________:118
6 	NPSWF32_11_5_502_110.dll 	F2166389_____________________________________________________________________ 	F_334370096____________________________________________________________________:517
7 	NPSWF32_11_5_502_110.dll 	F_917831355____________________________________________ 	F_334370096____________________________________________________________________:445
8 	NPSWF32_11_5_502_110.dll 	F1315696776________________________________ 	F_334370096____________________________________________________________________:409
9 	NPSWF32_11_5_502_110.dll 	F81047063_______________________________________ 	F1313573471__________________________________________________________________________________:180
10 	NPSWF32_11_5_502_110.dll 	F845925699_____________________________________ 	F_776920134____________________________________________________________________________________________:92
11 	NPSWF32_11_5_502_110.dll 	F_1395837734_____________________________________________________ 	F2050211588____________________________________________________________________________________________:499
12 	NPSWF32_11_5_502_110.dll 	F_653069593______________________________________________________________ 	F2050211588____________________________________________________________________________________________:1793
13 	xul.dll 	mozilla::plugins::BrowserStreamChild::StreamConstructed 	dom/plugins/ipc/BrowserStreamChild.cpp:62
14 	xul.dll 	mozilla::plugins::PluginInstanceChild::AnswerPBrowserStreamConstructor 	dom/plugins/ipc/PluginInstanceChild.cpp:2258
15 	xul.dll 	mozilla::plugins::PPluginInstanceChild::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp:2502
16 	xul.dll 	mozilla::plugins::PPluginModuleChild::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginModuleChild.cpp:1006
17 	xul.dll 	mozilla::ipc::RPCChannel::DispatchIncall 	ipc/glue/RPCChannel.cpp:485
18 	xul.dll 	mozilla::ipc::RPCChannel::Incall 	ipc/glue/RPCChannel.cpp:471
19 	xul.dll 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	ipc/glue/RPCChannel.cpp:398
20 	xul.dll 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:326
21 	xul.dll 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:334
22 	xul.dll 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:434
23 	xul.dll 	base::MessagePumpForUI::DoRunLoop 	ipc/chromium/src/base/message_pump_win.cc:214
24 	xul.dll 	base::MessagePumpWin::RunWithDispatcher 	ipc/chromium/src/base/message_pump_win.cc:53
25 	xul.dll 	base::MessagePumpWin::Run 	ipc/chromium/src/base/message_pump_win.h:78
26 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
27 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:194
28 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
29 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:485
30 	xul.dll 	XRE_StringToChildProcessType 	toolkit/xre/nsEmbedFunctions.cpp:213
31 	plugin-container.exe 	__tmainCRTStartup 	crtexe.c:552
32 	kernel32.dll 	BaseThreadInitThunk 	
33 	ntdll.dll 	__RtlUserThreadStart 	
34 	ntdll.dll 	_RtlUserThreadStart
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
Version: 17 Branch → 11.x
I could reproduce this issue while testing Bug 554154 .

STR:

1. I opened 10 different tabs:
http://www.mtv.com/
http://www.amazon.com/
http://www.greasespot.net/p/welcome.html?0.9.22
http://www.engadget.com/
http://edition.cnn.com/
http://www.prosport.ro/
http://www.itunes.com/
http://tmp.garyr.net/version_update.htm?version=0.3.8.7
http://coralietab.mozdev.org/whatsnew.php?cli=o&v=2.04.20110724
about:config
2. Set restore all tabs and after that restart browser.
3. Go to about:config are set browser.allTabs.previews to true.
4. Restart again browser.
5. Go to https://addons.mozilla.org/ro/firefox/ and install most popular addons and a couple Tab Addons (Fast Close Tabs one of them). 
6. After the addons (about 15) are completly instaled restart FF.
7. It will crash so press Restart Firefox.
8. About 25 tabs should be opened (the onces mentioned in step 1 + addons instaled main pages)
9. Crash will be reported in about:crash.
10. Try to close FF and another crash will appear.
... and it stopped spiking the day after.
Keywords: topcrash
It's #8 Flash crasher in Flash 11.8.800.94 across Firefox current channels.
Keywords: topcrash
it's #186 in 23.0.1 and #70 in 24beta on the plugins topcrash lists
Keywords: topcrash
This is by far the largest plugin crash on Dev Edition right now, with a really bad plugin crash rate in that 39 train atm - Aaron, should we track that in this bug or should we file a new one?
Flags: needinfo?(aklotz)
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #7)
> This is by far the largest plugin crash on Dev Edition right now, with a
> really bad plugin crash rate in that 39 train atm - Aaron, should we track
> that in this bug or should we file a new one?

Let's file a new one to track the spike.
Flags: needinfo?(aklotz)
OK, filed as bug 1156903.
The fix in bug 1156903 should take care of all instance of this crash, so I'm going to mark this one as a dupe.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1156903
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.