Closed Bug 813462 Opened 8 years ago Closed 8 years ago

Unable to send SMS from Contacts details

Categories

(Core :: DOM: Core & HTML, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla20
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: gerard-majax, Assigned: baku)

References

Details

Attachments

(1 file)

gecko: 0e7d3d2661760a3552fadc3164178e237058a954
gaia: b3344d5021137b59e98855d2c01badc8c3bf27c4

1- Open existing Contact
2- Tap "Message" button to send a message

Expected:
Open SMS app in edit mode with contact phone number filled.

Actual:
Nothing.
WFM with latest gecko + gaia.
Still reproducing with gaia at d42e3c9aea75cf6bae8395955954d272f9b0566f.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
It's actually NOT solved.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
As far as I can tell, logcat does NOT shows "is not from user input" when I hit this issue: so it's not blocked by the recent activies changes to only allow those that results from a user input.
After digging,
http://mxr.mozilla.org/mozilla-central/source/dom/activities/src/ActivitiesService.jsm#282 checks that the started activity has the correct fields regarding the manifest it evaluates.

In my case, it gives this activity:
I/Gecko   (   77): -- ActivitiesService.jsm 1353514648021 StartActivity: {"id":"{90304520-a147-4805-9755-e233ff1fe68a}","options":{"name":"new","data":{"type":"websms/sms","number":"+336xxxxxxxx"}},"manifestURL":"app://communications.gaiamobile.org/manifest.webapp","pageURL":"app://communications.gaiamobile.org/contacts/index.html"}

And that manifest being tested:
{"manifest":"app://sms.gaiamobile.org/manifest.webapp","name":"new","title":"Messages","icon":"app://sms.gaiamobile.org/style/icons/Sms.png","description":{"filters":{"type":"websms/sms"},"disposition":"window","href":"app://sms.gaiamobile.org/index.html"},"id":"e02Mrwao2k/LmuvMr4gbRBNHHyo="}

Obivously, the 'number' property is not present in description.filters.
I think it comes from the fix of bug 805292.
From SMS App it's impossible to create a Contact as well ... :(
Blocks: 812732
Priority: -- → P1
Assignee: nobody → amarchesini
The bug is that, in Bug 805292, comment 6, I wrote:

App: { type: 'foo', probA: ['a', 'b', 'c'], probB: 42 }
Request: { propC: 'foobar' }
Status: Reject - propC is unknown

This is wrong. If the property 'propC' is in the request, but it's unknown by the app, we should accept the app.
Attached patch patchSplinter Review
Attachment #684396 - Flags: review?(mounir)
Comment on attachment 684396 [details] [diff] [review]
patch

Review of attachment 684396 [details] [diff] [review]:
-----------------------------------------------------------------

This is hacky because that means you can create an activity with no payload and have *all* handlers showing up. But given how fkd up our filtering mechanism is, I guess we could try this solution.
Attachment #684396 - Flags: review?(mounir) → review+
blocking-basecamp: --- → ?
I agree. I would like to have a filter validation, or filter type, as such as:

"filters": {
  "number": { type: "string", required: true },
  "type": { type: "fixed", value: "sms" }
}

but I think now it's too late to change the manifest syntax. is it?
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/9e2462d9a974
Status: REOPENED → ASSIGNED
Component: Gaia::Contacts → DOM: Mozilla Extensions
Keywords: checkin-needed
OS: Gonk (Firefox OS) → All
Product: Boot2Gecko → Core
Hardware: ARM → All
Target Milestone: --- → mozilla20
blocking-basecamp: ? → +
https://hg.mozilla.org/mozilla-central/rev/9e2462d9a974
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
(In reply to Andrea Marchesini (:baku) from comment #11)
> I agree. I would like to have a filter validation, or filter type, as such
> as:
> 
> "filters": {
>   "number": { type: "string", required: true },
>   "type": { type: "fixed", value: "sms" }
> }
> 
> but I think now it's too late to change the manifest syntax. is it?

I don't think it is. We need some kind of schema language (ouch) to define the filters.
Component: DOM: Mozilla Extensions → DOM
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.