Cookies exceptions not saved&History settings not saved

RESOLVED DUPLICATE of bug 814554

Status

()

--
major
RESOLVED DUPLICATE of bug 814554
6 years ago
6 years ago

People

(Reporter: gbillios+mozilla, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
After I upgraded to F17 from F16 using the integrated update mechanism, cookie accept/deny popups started appearing even for sites that I had already chosen in the past and were in my exception list. 

Even if I chose accept/deny, next time I started firefox the same thing happened as if my selection was not saved. 

Also in option if I changed the History->Accept cookies from sites settings, it wasn't save after I clicked OK.  

I had to remove the old permissions.sqlite file to get a working environment again. The old cookies exception list remains intact but I still have to accept/deny all cookies from start. At least this time my selection is saved across sessions. 

This doesn't happen for a new profile but it was/is a great annoyance since I check every single cookie!

Comment 1

6 years ago
I've encountered the exact same problem upgrading from SeaMonkey "2.13.2" to "2.14". New cookie permissions appear in Data Manager during the current session, but are not saved on exit. This problem does _not_ occur with a new profile.  -JW

Comment 2

6 years ago
UPDATE: using an outside tool (sqlitebrowser), I deleted a number of existing permissions, reducing the size of "permissions.sqlite" from 623K to 26K. Everything now seems to be working normally.  -JW
(Reporter)

Comment 3

6 years ago
(In reply to J. Weaver Jr. from comment #2)
> UPDATE: using an outside tool (sqlitebrowser), I deleted a number of
> existing permissions, reducing the size of "permissions.sqlite" from 623K to
> 26K. Everything now seems to be working normally.  -JW

My permissions.sqlite was also around 690KB but again this file works with F16. Maybe the devs introduced some kind of limit in F17 ?

Comment 4

6 years ago
similar/same bug as Bug 814189
(Reporter)

Comment 5

6 years ago
(In reply to pal-moz from comment #4)
> similar/same bug as Bug 814189

thx for informing. I would say the basic bug is 814554

Comment 6

6 years ago
I'm having similar problems in Seamonkey 2.14.

A couple of things that I tried:

1) I renamed my cookies.sqlite to cookies.sqlite.save, and restarted Seamonkey.  No errors, but no change in behavior.  After the restart, both files are 525288 bytes.  I wonder if there's a size limit somewhere.

2) I went to a backup of profile, made under 2.12.1, and copied the cookies.sqlite file to my active profile.  Same symptoms -- cookie permissions prompts, each time a new session is started.

3) I also have Seamonkey 2.14 installed on a Linux installation (Ubuntu 12.04), installed from the Ubuntuzilla repository.  No problems there.  I don't have nearly as many permissions stored in the Ubuntu profile, but it's still several hundred.  filesize is also 524288 bytes.

Comment 7

6 years ago
Further follow-up...

I renamed permissions.sqlite, and things seem to be working OK.  Of course, I have to redo all my permissions.  I can live with that (as there's probably a bunch in my collection that aren't necessary), and I had expected to have to do that anyway.  In any case, having to do permissions once, rather than once per session is a huge improvement.
George, can you still reproduce the issue on FF 17.0.1 ?
Blocks: 814554
(Reporter)

Comment 9

6 years ago
No, everything seems ok with 17.0.1 .

Sorry for not confirming earlier.
No longer blocks: 814554
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814554
You need to log in before you can comment on or make changes to this bug.