The default bug view has changed. See this FAQ.

Intermittent b2g process crash when running Marionette tests on emulator

RESOLVED WORKSFORME

Status

Firefox OS
General
P4
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: swu, Unassigned)

Tracking

({crash, intermittent-failure})

unspecified
ARM
Gonk (Firefox OS)
crash, intermittent-failure

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: [b2g-crash])

(Reporter)

Description

4 years ago
Reported from bug 790463.

https://tbpl.mozilla.org/php/getParsedLog.php?id=17285452&tree=Mozilla-Inbound
(Reporter)

Comment 1

4 years ago
Another case:

https://tbpl.mozilla.org/php/getParsedLog.php?id=17292773&tree=Try&full=1
Keywords: crash
Whiteboard: [b2g-crash]
Keywords: intermittent-failure
Duplicate of this bug: 814695
blocking-basecamp: --- → ?
https://tbpl.mozilla.org/php/getParsedLog.php?id=17363760&full=1&branch=mozilla-inbound
We decided in triage that we can't block on this.  I'm marking it as a "soft" blocker (blocking-, P4).
blocking-basecamp: ? → -
Priority: -- → P4
https://tbpl.mozilla.org/php/getParsedLog.php?id=17398865&full=1&branch=mozilla-inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17440065&full=1&branch=mozilla-inbound

{
21:48:19     INFO - F/libc    (  182): Fatal signal 7 (SIGBUS) at 0x4138a9e8 (code=2)
21:48:19     INFO - I/DEBUG   (   35): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
21:48:19     INFO - I/DEBUG   (   35): Build fingerprint: 'Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/1254:eng/test-keys'
21:48:19     INFO - I/DEBUG   (   35): pid: 182, tid: 182  >>> /system/b2g/plugin-container <<<
21:48:19     INFO - I/DEBUG   (   35): signal 7 (SIGBUS), code 2 (BUS_ADRERR), fault addr 4138a9e8
21:48:19     INFO - I/DEBUG   (   35):  r0 4138a9e8  r1 00000000  r2 00000600  r3 80000000
21:48:19     INFO - I/DEBUG   (   35):  r4 00000000  r5 00000000  r6 00000000  r7 00000000
21:48:19     INFO - I/DEBUG   (   35):  r8 b00136ac  r9 0019a9e8  10 01128000  fp 400c8000
21:48:19     INFO - I/DEBUG   (   35):  ip 00000000  sp be9b2540  lr 00000000  pc b000393c  cpsr a0000010
21:48:19     INFO - I/DEBUG   (   35):  d0  0000000000000000  d1  0000000000000000
21:48:19     INFO - I/DEBUG   (   35):  d2  0000000000000000  d3  0000000000000000
21:48:19     INFO - I/DEBUG   (   35):  d4  0000000000000000  d5  41cb0b69ee800000
21:48:19     INFO - I/DEBUG   (   35):  d6  3f50624dd2f1a9fc  d7  3ede5bd803edab09
21:48:19     INFO - I/DEBUG   (   35):  d8  0000000000000000  d9  0000000000000000
21:48:19     INFO - I/DEBUG   (   35):  d10 0000000000000000  d11 0000000000000000
21:48:19     INFO - I/DEBUG   (   35):  d12 0000000000000000  d13 0000000000000000
21:48:19     INFO - I/DEBUG   (   35):  d14 0000000000000000  d15 0000000000000000
21:48:19     INFO - I/DEBUG   (   35):  scr 00000010
21:48:19     INFO - I/DEBUG   (   35):
21:48:19     INFO - I/DEBUG   (  183): debuggerd: Nov 28 2012 17:54:00
}
Duplicate of this bug: 818183
https://tbpl.mozilla.org/php/getParsedLog.php?id=17599768&tree=Mozilla-Inbound

{
11:39:21 ERROR - Traceback (most recent call last):
11:39:21 INFO - TEST-UNEXPECTED-FAIL | test_execute_async_script.py TestExecuteAsyncContent.test_execute_async_unload | MarionetteException: {u'from': u'conn92.marionette1', u'value': None}
11:39:21 ERROR - Traceback (most recent call last):
11:39:21 INFO - TEST-UNEXPECTED-FAIL | test_execute_async_script.py TestExecuteAsyncContent.test_execute_js_exception | MarionetteException: {u'ok': True, u'from': u'conn92.marionette1'}
11:39:21 ERROR - FAILED (errors=2)
11:40:00 ERROR - Return code: 10
11:40:00 ERROR - F/libc ( 172): Fatal signal 7 (SIGBUS) at 0x4139d088 (code=2)
11:40:00 ERROR - This usually indicates the B2G process has crashed
}

Bug 815676 seems to be working :-)
https://tbpl.mozilla.org/php/getParsedLog.php?id=17602567&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17603175&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17606596&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17628314&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17635122&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17667975&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17669487&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17758344&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=17726796&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17751206&tree=Mozilla-Inbound

Please can we make the B2G marionette runs abort earlier on than in most of these? Judging from comments on IRC, non-sheriffs are still having great trouble seeing the true cause of the failures amongst all the noise.
https://tbpl.mozilla.org/php/getParsedLog.php?id=17771043&tree=Mozilla-Inbound
(In reply to Ed Morley [UTC+0; email:edmorley@moco] from comment #17)
> https://tbpl.mozilla.org/php/getParsedLog.php?id=17751206&tree=Mozilla-
> Inbound
> 
> Please can we make the B2G marionette runs abort earlier on than in most of
> these? Judging from comments on IRC, non-sheriffs are still having great
> trouble seeing the true cause of the failures amongst all the noise.

Yes, it's high on our list of things to do.
https://tbpl.mozilla.org/php/getParsedLog.php?id=17675576&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17686957&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17700118&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17700688&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17700926&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17705444&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17704411&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17765161&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17742859&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17824369&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17828491&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17767883&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17846437&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17850945&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17879085&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17899335&tree=Mozilla-Inbound
Lots more nondescript failures:
https://tbpl.mozilla.org/php/getParsedLog.php?id=17894533&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17919012&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=17924915&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=18014871&tree=Mozilla-Inbound
Blocks: 823076
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.