Select Addresses blank if opened from Compose window with To/Cc/Bcc filled in

RESOLVED FIXED in seamonkey2.17

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: InvisibleSmiley, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression, relnote})

Trunk
seamonkey2.17
regression, relnote

SeaMonkey Tracking Flags

(seamonkey2.14 fixed, seamonkey2.15 fixed, seamonkey2.16 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
0. Ensure you have a mail account and contact(s) in the Personal Address Book
1. Open a Compose window (Ctrl+M)
2. Fill in at least one To, Cc or Bcc line
3. Click the Address icon or select Options/Select Addresses

Actual result: The list on the left (with headers Name, Email, Screen Name) is empty

Expected result: The list on the left shows your contacts. You will get this result if you have no (filled in) To, Cc or Bcc line in the Compose window.

Last known good: SM 2.13.2

First bad: 2.14b1

Nothing in the Error Console.
(Reporter)

Comment 1

5 years ago
It breaks here

http://mxr.mozilla.org/comm-central/source/suite/mailnews/addrbook/abSelectAddressesDialog.js#121

because gHeaderParser is undefined since bug 774069 removed it from abCommon.js.
Depends on: 774069
(Reporter)

Updated

5 years ago
Component: MailNews: Composition → MailNews: Address Book & Contacts
(Assignee)

Comment 2

5 years ago
Created attachment 684860 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #684860 - Flags: review?(jh)
(Reporter)

Updated

5 years ago
Attachment #684860 - Flags: review?(jh) → review+
(Assignee)

Comment 3

5 years ago
Pushed comm-central changeset 90c30f23e058.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: relnote
Resolution: --- → FIXED
(Assignee)

Comment 4

5 years ago
Comment on attachment 684860 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 774069
User impact if declined: Can't edit existing addreses using dialog
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #684860 - Flags: approval-comm-beta?
Attachment #684860 - Flags: approval-comm-aurora?
(Reporter)

Updated

5 years ago
Attachment #684860 - Flags: approval-comm-beta?
Attachment #684860 - Flags: approval-comm-beta+
Attachment #684860 - Flags: approval-comm-aurora?
Attachment #684860 - Flags: approval-comm-aurora+
(Reporter)

Updated

5 years ago
status-seamonkey2.17: affected → ---
Target Milestone: --- → seamonkey2.17
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/c181ca27c7fb
https://hg.mozilla.org/releases/comm-beta/rev/a47244f34da9
status-seamonkey2.15: affected → fixed
status-seamonkey2.16: affected → fixed

Updated

5 years ago
Duplicate of this bug: 816271

Comment 7

5 years ago
Comment on attachment 684860 [details] [diff] [review]
Proposed patch

[Triage Comment]
Attachment #684860 - Flags: approval-comm-release+
(Assignee)

Comment 8

5 years ago
Comment on attachment 684860 [details] [diff] [review]
Proposed patch

https://hg.mozilla.org/releases/comm-release/rev/a44252ba0f5d
(Assignee)

Updated

5 years ago
status-seamonkey2.14: affected → fixed

Updated

5 years ago
Duplicate of this bug: 816631
Duplicate of this bug: 817137
(Reporter)

Updated

5 years ago
tracking-seamonkey2.14: ? → ---
You need to log in before you can comment on or make changes to this bug.