Pref on the gum automation in mozilla-central

RESOLVED FIXED in mozilla20

Status

()

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jsmith, Assigned: jesup)

Tracking

Trunk
mozilla20
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia][blocking-gum+][qa-])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
We currently cannot pref on the basic gum automation in bug 781534 because of leaks (bug 814721) and a functional error with OS X opt builds (bug 814718). When those two bugs are fixed, let's pref on the automation on central.
(Reporter)

Updated

6 years ago
Depends on: 814718, 814721
(Reporter)

Updated

6 years ago
Blocks: 781534
(Reporter)

Updated

6 years ago
Whiteboard: [getUserMedia][blocking-gum+]
Any current tests which leak we should not push to mozilla-central but to the alder branch. As of bug 816489 we do not do final leak checks there.
We will pref on mochitests for WebRTC once all the leaks have been fixed. That means we will not cherry-pick. But once nothing leaks anymore we will take the tests which have been landed on alder in the meantime.
Depends on: 812648
No longer depends on: 814721
(Assignee)

Updated

6 years ago
Assignee: nobody → hskupin
Priority: -- → P1
(Reporter)

Updated

6 years ago
Depends on: 823520
(Reporter)

Updated

6 years ago
No longer depends on: 812648
(Assignee)

Updated

6 years ago
Depends on: 802538
(Reporter)

Updated

6 years ago
No longer depends on: 823520
(Assignee)

Updated

6 years ago
Assignee: hskupin → rjesup
Summary: Pref on the gum automation from bug 781534 on mozilla central → Pref on the gum automation in mozilla-central
(Assignee)

Comment 3

6 years ago
Created attachment 696457 [details] [diff] [review]
Enable getUserMedia() mochitests

Moving patch from Bug 802538 to here, carrying forward r=whimboo
Attachment #696457 - Flags: review+
Duplicate of this bug: 825594
(Reporter)

Comment 5

6 years ago
Comment on attachment 696457 [details] [diff] [review]
Enable getUserMedia() mochitests

This is missing one of the three tests that need to be prefed on. Patch coming to fix this.
Attachment #696457 - Attachment is obsolete: true
Attachment #696457 - Flags: review-
(Reporter)

Comment 6

6 years ago
Created attachment 696902 [details] [diff] [review]
Enable gum tests on mozilla central
(Reporter)

Updated

6 years ago
Attachment #696902 - Flags: review?(rjesup)
(Assignee)

Updated

6 years ago
Attachment #696902 - Flags: review?(rjesup) → review+
(Reporter)

Comment 7

6 years ago
I *think* we can land this now given the two issues have been resolved that were causing the failures originally - last try run in bug 814718 indicates I *think* we should be okay to land this.
Keywords: checkin-needed
(Assignee)

Comment 8

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c78f5379558a

Once more into the fray!
Target Milestone: --- → mozilla20
(Reporter)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c78f5379558a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Whiteboard: [getUserMedia][blocking-gum+] → [getUserMedia][blocking-gum+][qa-]
(Reporter)

Updated

6 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.