Last Comment Bug 825594 - Pref on mozGetUserMedia by default
: Pref on mozGetUserMedia by default
Status: VERIFIED FIXED
[getUserMedia][blocking-gum+]
: dev-doc-complete
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla20
Assigned To: [:jesup] on pto until 2016/7/5 Randell Jesup
: Jason Smith [:jsmith]
Mentors:
Depends on: 799417 814807 822956 826029 826576 827007
Blocks: 796463
  Show dependency treegraph
 
Reported: 2012-12-31 05:33 PST by Jason Smith [:jsmith]
Modified: 2013-04-09 08:52 PDT (History)
7 users (show)
jsmith: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Pref on mozGetUserMedia by default (1.22 KB, patch)
2013-01-04 08:59 PST, [:jesup] on pto until 2016/7/5 Randell Jesup
justin.lebar+bug: review-
Details | Diff | Review
Pref on mozGetUserMedia by default (1.84 KB, patch)
2013-01-04 13:22 PST, [:jesup] on pto until 2016/7/5 Randell Jesup
no flags Details | Diff | Review
Pref on mozGetUserMedia by default (865 bytes, patch)
2013-01-04 13:36 PST, [:jesup] on pto until 2016/7/5 Randell Jesup
justin.lebar+bug: review+
Details | Diff | Review

Description Jason Smith [:jsmith] 2012-12-31 05:33:43 PST
When we resolve the blockers associated with mozGetUserMedia, we'll need to pref on mozGetUserMedia in builds by default. This bug tracks that work.
Comment 1 Maire Reavy [:mreavy] (On PTO until July 5th) 2012-12-31 06:24:40 PST
I think Bug 814807 currently covers this.

*** This bug has been marked as a duplicate of bug 814807 ***
Comment 2 Jason Smith [:jsmith] 2012-12-31 08:03:51 PST
bug 814807 talks about the gum automation. This about the gum feature.
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-04 08:59:40 PST
Created attachment 697940 [details] [diff] [review]
Pref on mozGetUserMedia by default
Comment 4 Justin Lebar (not reading bugmail) 2013-01-04 13:18:32 PST
Comment on attachment 697940 [details] [diff] [review]
Pref on mozGetUserMedia by default

As gavin pointed out, we need to change this value in all.js.
Comment 5 [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-04 13:22:44 PST
Created attachment 698060 [details] [diff] [review]
Pref on mozGetUserMedia by default

left the second media.navigator.enabled because getUserMedia for still images on Andriod is supposed to still work if you --disable-webrtc
Comment 6 [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-04 13:36:48 PST
Created attachment 698065 [details] [diff] [review]
Pref on mozGetUserMedia by default
Comment 7 Justin Lebar (not reading bugmail) 2013-01-04 13:38:09 PST
Comment on attachment 698065 [details] [diff] [review]
Pref on mozGetUserMedia by default

I have no idea what this pref does, so let's call this rs=me.
Comment 8 Henrik Skupin (:whimboo) 2013-01-04 13:41:38 PST
Shouldn't we wait with the patch until bug 802694 has been fixed?
Comment 9 [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-04 15:19:01 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/061f75208064
Bug 802694 is about PeerConnection, not getUserMedia
Comment 10 Phil Ringnalda (:philor) 2013-01-05 16:27:53 PST
https://hg.mozilla.org/mozilla-central/rev/061f75208064
Comment 11 Jason Smith [:jsmith] 2013-01-24 20:04:43 PST
Verified on 1/24 that we are prefed on by default on nightly.
Comment 12 Jason Smith [:jsmith] 2013-01-26 07:16:46 PST
Already covered by existing gum automation.
Comment 13 Matt Brubeck (:mbrubeck) 2013-04-09 08:52:46 PDT
I updated the Gecko version information on
https://developer.mozilla.org/en-US/docs/WebRTC/navigator.getUserMedia

Note You need to log in before you can comment on or make changes to this bug.