Closed Bug 814856 Opened 7 years ago Closed 6 years ago

"SD card" should be replaced with more generic "memory card" in settings.properties and camera.properties

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: flod, Assigned: heroldtom)

Details

(Keywords: late-l10n)

Attachments

(1 file)

apps/settings/settings.properties
media-storage-details=Photos, videos and music are stored on the SD card. See media storage for details.

apps/camera/camera.properties
size-limit-reached = You have run out of space on your SD card.

All other strings use a more generic "memory card"
I have resolved this bus.Please assign it to me.
Hi Neeraj, is this issue already solved on GitHub? I saw also you comment in bug 861093.
Hello :flod, Here is the pull request link :  https://github.com/mozilla-b2g/gaia/pull/9722. At the same time I can see following message on Travis : 

The Travis CI build could not complete due to an error

what to do now?
Sorry but I can't help you with that, you need to talk with a developer (I'm not).

Anyway that pull is not ok: if you change a string, you need to replace the ID.
Hello Francesco Lodolo, 

Thanks for quick reply. 

What do you mean by "replace the ID" ? If I understand right, you mean is creating new ID and using new one.
(In reply to Neeraj from comment #5)
> What do you mean by "replace the ID" ? If I understand right, you mean is
> creating new ID and using new one.

Yes, that's the usual process. But again, you should really talk with Gaia's developers because strings are a complicate matter and I don't want to give you wrong advices ;-)
Neeraj, please refer to [1] for how to submit a gaia patch.

If you confirmed that the Travis build error doesn't result from your commit (for example, you did nothing on the files with error and builds nearby also meet identical error), just ask for review. Please refer to [2] for Settings module owners and peers as reviewer candidates. Also in my opinion, you should squash your commits into 1 instead of 12 seperate commits. To take this bug, please click 'take' in 'Assigned to' field of this bug by your own.

[1] https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Platform/Gaia/Hacking#Submitting_a_patch
[2] https://wiki.mozilla.org/Modules/FirefoxOS#Settings
Looks like this was resolved. Please close the issue. Thank you.
Attached file Link to pull request
Assignee: nobody → therold
Attachment #787713 - Flags: review?(francesco.lodolo)
Flags: needinfo?(therold)
Comment on attachment 787713 [details]
Link to pull request

I'm not entitled to do reviews, expecially on Gaia, but for sure this patch is not OK.

If you change a string, you need to change the ID as well.
Attachment #787713 - Flags: review?(francesco.lodolo) → feedback-
Attachment #787713 - Attachment mime type: text/plain → text/html
Attachment #787713 - Flags: feedback?(kgrandon)
Attachment #787713 - Flags: feedback-
Comment on attachment 787713 [details]
Link to pull request

This looks ok to me. I'm going to flag :kaze and :djf for review of their app-specific code just so they are aware of the changes. Thanks!
Attachment #787713 - Flags: feedback?(kgrandon)
Attachment #787713 - Flags: feedback?(kaze)
Attachment #787713 - Flags: feedback?(dflanagan)
Attachment #787713 - Flags: feedback+
Comment on attachment 787713 [details]
Link to pull request

Sorry, meant to flag for review.
Attachment #787713 - Flags: review?(kaze)
Attachment #787713 - Flags: review?(dflanagan)
Attachment #787713 - Flags: feedback?(kaze)
Attachment #787713 - Flags: feedback?(dflanagan)
Comment on attachment 787713 [details]
Link to pull request

Thanks for fixing this Tom and Kevin.

I've commented on github that I don't think we should refer to a "card" of any form because Leo devices also have internal storage and will working without a card.
Attachment #787713 - Flags: review?(dflanagan) → review-
@Kaze: Are you OK with djf's suggestion for the "media-storage-details" string as discuessed in the pull request?

For reference: "I suspect it is okay to leave the card reference here, but maybe Kaze will have ideas about how to change that. Like "Photos, videos and music are stored separately from apps. See media storage for details."
Flags: needinfo?(kaze)
Agreed: we can’t assume that (media storage == SD card) and (app storage == internal memory), so we have to go with more generic descriptions. I think this makes sense (in djf we trust ^^):

> storage-size-limit-reached = You have run out of storage space.

> memory-storage-details=Photos, videos and music are stored separately from apps. See media storage for details.
Flags: needinfo?(kaze)
I have changed both strings as suggested by you. I think this ready for review now. kaze can you review this, please?
Merged on master: https://github.com/mozilla-b2g/gaia/commit/9da56131d28493af5452052132f47996a4cd0aa8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 787713 [details]
Link to pull request

Forgot to r+…
Attachment #787713 - Flags: review?(kaze) → review+
You need to log in before you can comment on or make changes to this bug.