Closed Bug 814944 Opened 10 years ago Closed 10 years ago

Custom installed search engines have no/blank favicon

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 813346

People

(Reporter: aryx, Unassigned)

Details

Firefox for Android trunk nightly 20121124, Android 4.1.2 (stock), Google Nexus S

Custom installed search engines have no/a blank favicon.

Steps to reproduce:
1. Go to https://bugzilla.mozilla.org/
2. Tap on "Install the quick search plugin" and confirm the install.
3. Type a strange letter chain into the url bar so you only see the search engines.

Actual result:
Empty/totally white favicon.

Expected result:
Favicon from search engine

This also happens to search engines which were installed before the changes to the favicon db and ones installed from https://addons.mozilla.org
I see a "java.lang.IllegalArgumentException: bad base-64" exception after adding the search engine, so this sounds like bug 813346.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813346
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.