Closed Bug 815295 Opened 9 years ago Closed 9 years ago

Disable the Downloads Panel in Firefox 19

Categories

(Firefox :: Downloads Panel, defect, P1)

19 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 19
Tracking Status
firefox19 + verified

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(1 file)

We'll want to disable this about a week or two before the next merge (which is currently scheduled during the week of 2013-01-06).

So basically, we should shut this off on Aurora just before the holidays start.
Assignee: nobody → mconley
OS: Windows 7 → All
Hardware: x86_64 → All
Version: Trunk → 19 Branch
Depends on: 799436
The patch is the same used to disable in 18 (thus added dependency)
We should do this just before the christmas holidays, the next merge is on 7th jan, so that looks like about the requested 2-weeks-before-merge.
This should land before Friday.
(In reply to Marco Bonardo [:mak] from comment #4)
> This should land before Friday.

This applies cleanly for me. Does this need an r+, or should I just request approval for mozilla-aurora?
just get approval, this went through enough landings already to required further reviews :)
Comment on attachment 688887 [details] [diff] [review]
Disable the Downloads Panel in Aurora 19

As Aurora 19 approaches the uplift, we want to disable the Downloads Panel, since we only left it enabled on Aurora for testing.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
N/A

User impact if declined: 
Users get a half-baked Downloads Panel experience in Beta.

Testing completed (on m-c, etc.):
This patch has been used to disable the Panel at least two other times - seems to work well.

Risk to taking this patch (and alternatives if risky): 
None.

String or UUID changes made by this patch: 
None.
Attachment #688887 - Flags: approval-mozilla-aurora?
Priority: -- → P1
Attachment #688887 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/8d77162e2613
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: verifyme
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Followup to disable browser_first_download_panel.js, which was timing out.
https://hg.mozilla.org/releases/mozilla-aurora/rev/85d4b438e27d
Verified as fixed on Firefox 19 beta 1 - the downloads panel is disabled (per default the preference browser.download.useToolkitUI is set to true in about:config).

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.8.2:
Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.