GCLI commands with optional options have misleading synopsis

RESOLVED DUPLICATE of bug 799769

Status

()

Firefox
Developer Tools: Graphic Commandline and Toolbar
RESOLVED DUPLICATE of bug 799769
5 years ago
5 years ago

People

(Reporter: Michael Beckwith, Unassigned)

Tracking

18 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121119042013

Steps to reproduce:

Ran the screenshot command via the Developer Toolbar


Actual results:

Synopsis information is not uptodate with current method of adding parameters.


Expected results:

New --flag style should have been shown instead of "screenshot false true 0" etc

Updated

5 years ago
Component: Untriaged → Developer Tools

Comment 1

5 years ago
Michael, could you please attach the file you used screenshot with to this bug report?

We need to reproduce the bug in order to cofirm it, and I couldn't reproduce it with Firefox 18 or 20 until now.
Flags: needinfo?(tw2113)
Michael is referring to typing the --arguments, which aren't immediately obvious in gcli. For example, writing 'screenshot file' would show an [options] placeholder, which signals that extra arguments can be added, but there's no way of discovering that typing -- is required to display them. This bug affects all commands that use this variable-number-of-arguments pattern. CCing Joe.
Flags: needinfo?(tw2113)
OS: Mac OS X → All
Hardware: x86 → All

Comment 3

5 years ago
Thanks for the details, Victor.

Reproducible on the latest Nightly too (11/26).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Changing the summary of the bug to reflect a general use case
Summary: Devtools screenshot help Synopsis needs updated to new syntax → Commands with optional options have misleading synopsis in the "help <command>" popup
Agreed.

There is an extenuating circumstance here in that Kevin's video highlights the old way. Also it could be argued that using '-' (you only need one) is common-place in command lines.

However that's not to say that we shouldn't improve things, and it's something I'll bear in mind.

Thanks for the report.
Summary: Commands with optional options have misleading synopsis in the "help <command>" popup → GCLI commands with optional options have misleading synopsis
(Reporter)

Comment 6

5 years ago
Still need anything from me? or are we good to go?
(In reply to Michael Beckwith from comment #6)
> Still need anything from me? or are we good to go?

I think we understand the problem, thanks.
New component triage. Filter on "Lobster Thermidor aux crevettes with a Mornay sauce"
Component: Developer Tools → Developer Tools: Graphic Commandline and Toolbar
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799769
You need to log in before you can comment on or make changes to this bug.