Closed Bug 815547 Opened 8 years ago Closed 8 years ago

[Apps] Inconsistent app attribute status when download error

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

RESOLVED FIXED
mozilla20
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: arcturus, Assigned: ferjm)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 2 obsolete files)

Currently we have two ways of receiving a 'downloadError', in both we find some inconsistences.

- By calling app.cancelDownload:
    -> Hosted App: (looking good)
        -> app.installState: pending
        -> app.downloading: false
    -> Packaged App: (looking not that good)
        -> app.installState: pending
        -> app.downloading: *true*

- By network error:
    -> Hosted App: (looking good)
        -> app.installState: pending
        -> app.downloading: false
    -> Packaged App: (looking not that good)
        -> app.installState: *undefined*
        -> app.downloading: false
blocking-basecamp: --- → ?
Blocks: app-install
Assignee: nobody → ferjmoreno
Attached patch patch (obsolete) — Splinter Review
Assignee: ferjmoreno → fabrice
blocking-basecamp: ? → +
Attached patch wip2 (obsolete) — Splinter Review
I can confirm that the previous patch works. I only added the fix for packaged apps error due to connection errors.
Attachment #686092 - Flags: review+
Assignee: fabrice → ferjmoreno
Attachment #685589 - Attachment is obsolete: true
Attached patch v3Splinter Review
More apps state love.
Attachment #686092 - Attachment is obsolete: true
Attachment #686501 - Flags: review?(fabrice)
Comment on attachment 686501 [details] [diff] [review]
v3

Review of attachment 686501 [details] [diff] [review]:
-----------------------------------------------------------------

I hate this code more and more. It's time for a state machine based rewrite...
Attachment #686501 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/5d2fb47b6278
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Whiteboard: [qa-]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.