Closed Bug 816133 Opened 7 years ago Closed 6 years ago

Brightness default value should not be automatic

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dcoloma, Unassigned)

References

Details

Attachments

(1 file)

Auto brightness is the default value when switching on the device, i.e. when the First Time Experience is launched. Auto brightness leads to a very dark screen (see bug 809645). We should configure the brightness value to something that ensures the screen is bright enough (maybe 100%?).
See also bug 865180.
blocking-b2g: --- → leo?
Adding qawanted to repro - we haven't been able to in recent memory. Please check under different lighting conditions.

leo+ if this is reproducible and a v1.1 regression.
Keywords: qawanted
Which device would you like QA to investigate? Not clear from the bug which device the problem is happening on.
I have two phones side by side this morning - the Buri phone looks fine with "Adjust Automatically" set, while the Ikura phone looks dark with the same setting.
The Buri phone in Comment 4 has a partner build on it, the Ikura has one of our Commercial RIL builds on it.
Daniel - What devices were you able to reproduce this bug on in your initial report?
Flags: needinfo?(dcoloma)
It was Unagi/Otoro. I think the problem was that the algorithm used to calculate the brightness was not very accurate, situation improved after bug 809645 landed.
Flags: needinfo?(dcoloma)
Triage 5/3 - Leo- per comment 7. Bug mentioned in comment 1 should be tracked in parallel.
blocking-b2g: leo? → ---
Tested this on Unagi with:

Environmental  Variables:
Unagi Build ID: 20130503070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8becaf2a0bc7
Gaia: b0aca0dd1e2955e11190ede725e1fb9ee596438b

Also on Leo with:

Environmental  Variables:
Leo Build ID: 20130503070204
Kernel Date: Apr 25
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8becaf2a0bc7
Gaia: b0aca0dd1e2955e11190ede725e1fb9ee596438b

On both:

When launching FTU from Settings - Developer - "Launch first time use" the screen is dim for only a few seconds, then goes bright thereafter. See video of this at http://youtu.be/372mFupKLp8

When launching FTU by "Reset Phone" the screen never is dim. 

After FTU when checking the brightness in Settings - Display, the "Adjust automatically" is checked, and the brightness is fine. When unchecking this the brightness shows up as full.
Keywords: qawanted
Comment on attachment 8344961 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14518

This should not be the default, since it works poorly on most devices until configured by OEM.

If OEMs want to enable by default, they should do it in their distributions, after testing and calibrating for the specific device.
Attachment #8344961 - Flags: review?(ehung)
Comment on attachment 8344961 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14518

I'm good to have it default off. Thanks for patch it. :)
Attachment #8344961 - Flags: review?(ehung) → review+
Thanks for review Evelyn! Merged:

https://github.com/mozilla-b2g/gaia/commit/669956afc3e6e610080590ff1e8937ce22449eeb

There was a Travis failure on UI test, but it's unrelated. Filed bug 948690 for it.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Now that bug 1042673 is fixed, can we try to reenable it by default?
Flags: needinfo?(dietrich)
Once we verify that the new behavior is acceptable across multiple devices and all lighting conditions, yes we should do that (in a new bug, not this one).
Flags: needinfo?(dietrich)
See Also: → 1109473
You need to log in before you can comment on or make changes to this bug.