Make Marionette use mozdevice/mozb2g

RESOLVED DUPLICATE of bug 997244

Status

Testing
Marionette
RESOLVED DUPLICATE of bug 997244
5 years ago
4 years ago

People

(Reporter: jgriffin, Unassigned)

Tracking

Trunk
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [runner])

(Reporter)

Description

5 years ago
We have a lot of adb-related code in emulator.py, and some b2g helper methods like 'restart_b2g' that should belong in mozb2g.

We should make Marionette use mozdevice and mozb2g, updating the latter as necessary.

In particular, the B2GMixin class of mozb2g is written with the assumption that it will be used by code that is using Marionette, and some of it won't work when used by Marionette itself directly; there's a lot of code that tries to automatically manage Marionette sessions that we probably don't want when used by Marionette itself.

We'll probably end up refactoring it to make a lower-level devicemanager mixin that doesn't use Marionette, and then a higher-level one that incorporates that with some automatic Marionette session management.
(Reporter)

Updated

5 years ago
Blocks: 813300
Whiteboard: [runner]
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997244
You need to log in before you can comment on or make changes to this bug.