Table backgrounds don't print, starting from FX17

RESOLVED FIXED in Firefox 20

Status

()

defect
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: zuikkis, Assigned: khuey)

Tracking

({regression})

17 Branch
mozilla22
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox17 wontfix, firefox18+ wontfix, firefox19+ wontfix, firefox20+ verified, firefox21 verified, firefox22 fixed, firefox-esr17 wontfix)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121120042406

Steps to reproduce:

Open a page with tables that have background images, for example:
http://www.tizag.com/htmlT/htmlbackground.php

Page setup has "print background images" and "print background colors" checked.




Actual results:

In print preview, the table background is not visible. Also if printed, the background is not visible.


Expected results:

Table backgrounds were visible in FX16, so something is changed.

I have confirmed the bug on Ubuntu and Windows XP using Firefox 17, and a friend tested with Firefox 18 beta and it was the same.

Comment 1

7 years ago
Confirmed, FF17+ fail to print (preview & output) the background image in the tables.

Here is the regression range. I'm not able to test the build of 2012-08-15 because printing that webpage crashes this build. And I think the regression is here, by fixing the printing crash, this bug has appeared.

m-c
good=2012-08-14
bad=2012-08-16
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=22288130fea2&tochange=50e4ff05741e
Status: UNCONFIRMED → NEW
Component: Untriaged → Printing: Output
Ever confirmed: true
Product: Firefox → Core

Comment 2

7 years ago
There are 2 regression at least.
#1 Regressed by Bug 697230
   no backgound image printed (*and also no backgound image in normal view, but this was fixed by Bug 783162)

#2 Regressed by Bug 792314
   no backgound image and no backgound color printed

I've filed separate Bug 816603 for the regression #2 .


#1 Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/3b46b03dff5c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120815053101
Bad(no backgound image (and also no backgound image in normal view)):
http://hg.mozilla.org/mozilla-central/rev/d67c02074ced
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120815065301
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3b46b03dff5c&tochange=d67c02074ced

In local build
Last Good: 5709499c7c66
First Bad: 5c730c1f2274 +d5e42dcb36fd+d67c02074ced
Triggered by:
5c730c1f2274	Kyle Huey — Bug 697230: Part 1 - Centralize style image observers. r=bz

Comment 3

7 years ago
Posted image Screenshot (obsolete) —

Comment 4

7 years ago
Posted file reduced html zipfile (obsolete) —

Updated

7 years ago
Blocks: 783162
Kyle - what are the options here? Is there a forward fix on the horizon or can you look into backing out some or all of bug 697230 and take a different approach so we can reverse this regression?  We're too late for 17, unfortunately but 18 is still in beta and we could take a safe fix or a backout there.
Bug 697230 was a really important change and this is a minor regression, so we're not going to back it out to fix this.
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #6)
> Bug 697230 was a really important change and this is a minor regression, so
> we're not going to back it out to fix this.

Kyle, any update on if there a low risk forward fix in progress to make it into FF18 timeframe  ?
Johnny - I know Kyle is swamped with B2G work. Anybody else who can take a look at this in the FF19 timeframe?
Assignee: khuey → jst
Duplicate of this bug: 819922
carrying tracking forward to encompass 20 on Aurora now.
This has missed FF19b4, and is therefore no longer eligible for resolution in that Firefox version.
Kyle should have cycles to look into this very soon, assigning to him.
Assignee: jst → khuey
I debugged it and understand whats going wrong.  Not quite sure how to fix it yet.
Posted patch PatchSplinter Review
This also fixes another bug we found where hiding and showing a subframe "loses" background attributes.
Attachment #686674 - Attachment is obsolete: true
Attachment #686703 - Attachment is obsolete: true
Attachment #717449 - Flags: review?(bzbarsky)
Comment on attachment 717449 [details] [diff] [review]
Patch

r=me
Attachment #717449 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/8ee9a76cb582
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Comment on attachment 717449 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 697230
User impact if declined: Background attributes will be ignored when printing or when the visibility of a frame is dynamically altered and pages will be rendered without their backgrounds.
Testing completed (on m-c, etc.): On m-c, has automated tests
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: N/A
Attachment #717449 - Flags: approval-mozilla-beta?
Attachment #717449 - Flags: approval-mozilla-aurora?
Comment on attachment 717449 [details] [diff] [review]
Patch

Thanks for adding the tests too, approving for uplift.
Attachment #717449 - Flags: approval-mozilla-beta?
Attachment #717449 - Flags: approval-mozilla-beta+
Attachment #717449 - Flags: approval-mozilla-aurora?
Attachment #717449 - Flags: approval-mozilla-aurora+
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0

Verified as fixed on Firefox 20 beta 2 (buildID: 20130227063501). 
The background image is properly printed after turning on Print Background Colors and Print Background Images.
Flagging for verification in Firefox 21 and 22.
Keywords: verifyme
Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130423212553

Verified as fixed on Firefox 21 beta 4: - the background image is printed when Print Background Colors and Print Background Images are enabled.
this doesn't meet ESR uplift criteria, wontfixing.

Updated

6 years ago
Blocks: 845197

Comment 25

6 years ago
Bug still exist on Firefox 23.0.1, running win 8 64bits on both, normal and private modes.

Comment 26

6 years ago
(In reply to sukhoi47 from comment #25)
> Bug still exist on Firefox 23.0.1, running win 8 64bits on both, normal and
> private modes.

This bug is fixed, file a new bug with STR and testcase, please.
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.