Closed Bug 816988 Opened 9 years ago Closed 2 years ago

Can't debug scratchpad scripts in the browser debugger

Categories

(DevTools Graveyard :: Scratchpad, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: rcampbell, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [chrome-debug])

Run a script from a scratchpad in a Browser Context, ideally something that will stick around in a timer or similar.

Open a Browser Debugger and search for Scratchpad.

The script will appear in the Debugger list (probably as Scratchpad/1 or 2) but selecting it will only display "Loading..." in the Source area.
for bonus points, making scratchpad scripts show up in the content debugger would be to.
Seems like a dupe of bug 813087, but you focus on the script we pass to eval, which is a more general problem. I don't think we have a solution until bug 637572 is fixed.
similar but different. This is mostly about the script showing up in the list but not being accessible. I agree that bug 637572 would fix it.
Depends on: 637572
filter on BLACKEAGLE.
Priority: -- → P3
Whiteboard: [chrome-debug]
Duplicate of this bug: 903214
Depends on: dbg-source
No longer depends on: 637572
Summary: Unable to debug Scratchpad scripts in the Browser Debugger → Can't debug scratchpad scripts in the browser debugger
Duplicate of this bug: 1109223
any news on this bug ?
(In reply to inscription from comment #7)
> any news on this bug ?

I'm really sorry, but this bug is currently not on anyone's radar :-(

I'd love to look into it myself, but am too busy with service worker debugging at the moment.
Product: Firefox → DevTools
Blocks: dbg-chrome
Component: Debugger → Scratchpad

Scratchpad was removed in Bug 1519103 (Firefox 72). You can check the alternative in https://wiki.developer.mozilla.org/en-US/docs/Tools/Deprecated_tools#Scratchpad .

The Scratchpad bug list was reviewed and I think this bug can be safely closed.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.