Directory server drop down listbox changes size based on Theme selection

VERIFIED DUPLICATE of bug 88010

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 88010
17 years ago
17 years ago

People

(Reporter: yulian chang, Assigned: Joe Hewitt (gone))

Tracking

({modern, polish})

Trunk
modern, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Creating New Directory with long long Name will expand the 
dropdown list in the Pref window and even cut out Edit Directories button
button.

Except Linux,Wins and Mac have this problem.
(Reporter)

Updated

17 years ago
QA Contact: esther → yulian

Comment 1

17 years ago
It does not happen on my windows machine if I am using classic skin.
Yulian can you check if that is the case on all platforms.

Updated

17 years ago
Keywords: polish
Priority: -- → P3
Target Milestone: --- → mozilla0.9.2

Comment 2

17 years ago
This happens with the dropdown listboxes in mail/news Account Settings-> copies 
and folders pane. This happens only with modern skin.
I think this is a duplicate of bug 67597.
Yulian can you verify that it is the case?
Keywords: modern
OS: Windows NT → All
Hardware: PC → All
(Reporter)

Comment 3

17 years ago
True with Windows build.
But the problem still happens on Mac no matter with modern or Classic skin.

Updated

17 years ago
Blocks: 17880
(Reporter)

Comment 4

17 years ago
This happens with modern skin on all platforms. But on Mac it happens with
classic skin too.
I see this problem with the drp down listbox in Mail/News Account Settings ->
copies and folders if you have really long account name.
Summary: long Name forces Edit Directories button out → drop down listbox changes size based on selection

Comment 5

17 years ago
Reassigning this bug to hewitt
Assignee: srilatha → hewitt

Comment 6

17 years ago
seems like this is an xptoolkit issue. the skin cannot control this behavior.  

Comment 7

17 years ago
*** Bug 83586 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
this happens in both themes - the menulist isn't properly sizing itself to the
width of the menupopup, which sounds like an xptoolkit bug
Assignee: hewitt → trudelle
Component: Address Book → XP Toolkit/Widgets
Product: MailNews → Browser
QA Contact: yulian → aegis

Comment 9

17 years ago
Please review http://www.mozilla.org/quality/bug-writing-guidelines.html

As it stands, this bug report is not usable. Please give clear steps to 
reproduce.

Unsetting milestone for owner's review.

And removing the spurious blocker (how a bug that never mentions LDAP, can 
somehow block LDAP is beyond me).
No longer blocks: 17880
Target Milestone: mozilla0.9.2 → ---

Comment 10

17 years ago
->invalid.  
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

17 years ago
Modify Summery.

Steps to reporduce:
1. launch Browser
2. Change the Theme to Modern, Prefs|Appearance|Themes|Modern
3. Click "Apply Modern" button then click "OK" button
4. restart browser to make sure Browser is in Modern skin
5. Bring up Addressing Preference panel, Edit|Preferences|Mail and
Newsgroups|Addressing
6. In Address Autocompletion panel,check the box for "Directory Server:"
7. Click "Edit Directories" button to bring up LDAP Directory Servers window
8. Click Add button 
9. Directory Server Properties window appears
10. Type in a long long name (about 50 characters)in "Name" text box
11. type in whatever in "HostName" text box then click OK
12. Click OK to dismiss LDAP Directory Servers window
13. Back to Addressing preferences window
14. In LDAP Directory Server drop down listbox, choose the long Directory Name
created form Step 10
15. You see the long name pulls the border of "Address Autocompletion" ,"Email
Address Collection" beyond the Preferences window size and forces the "Edit
Directories" button out of the widnow

With Modern Theme, this problem happens on all platforms: Windows, Linux and Mac.

With Classic Theme, this problem happens on Macs only.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: drop down listbox changes size based on selection → Directory server drop down listbox changes size based on Theme selection

Comment 12

17 years ago
Thanks for the clear steps. Now it is clear to all: it happens in Mac Classic
and in Modern, but not with Win Classic or with no skin applied, so it is the
skin which is the determining factor. 

In Win Classic (or "naked"), this text does get cropped. Perhaps that needs to 
be defined, if it isn't for the other bindings that are used. 

-> hewitt
Assignee: trudelle → hewitt
Status: REOPENED → NEW

Comment 13

17 years ago
Created attachment 38171 [details]
simple test case. [application/vnd.mozilla.xul+xml]
(Assignee)

Comment 14

17 years ago

*** This bug has been marked as a duplicate of 88010 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
vfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.