Intermittent browser_cmd_calllog.js | Test timed out

RESOLVED FIXED in Firefox 21

Status

defect
P1
normal
RESOLVED FIXED
7 years ago
11 months ago

People

(Reporter: RyanVM, Assigned: miker)

Tracking

({intermittent-failure})

20 Branch
Firefox 21
x86
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=17507712&tree=Mozilla-Inbound

Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-browser-chrome on 2012-11-30 16:12:37 PST for push cd51ab1d33f5
slave: talos-r3-w7-100

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog.js | Console message: [JavaScript Warning: "TypeError: function WCF_logConsoleAPIMessage does not always return a value" {file: "chrome://browser/content/devtools/webconsole.js" line: 1194 column: 4 source: "    return node;
"}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog.js | Console message: [JavaScript Warning: "TypeError: function WCF_logNetEvent does not always return a value" {file: "chrome://browser/content/devtools/webconsole.js" line: 1374 column: 4 source: "    return messageNode;
"}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog.js | Console message: [JavaScript Warning: "TypeError: function WCF__outputMessageFromQueue does not always return a value" {file: "chrome://browser/content/devtools/webconsole.js" line: 1955 column: 4 source: "    return lastVisible ? node : null;
"}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog.js | Console message: [JavaScript Warning: "TypeError: function CommandController_isCommandEnabled does not always return a value" {file: "chrome://browser/content/devtools/webconsole.js" line: 3915}]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog.js | Test timed out
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Updated

7 years ago
Blocks: 788977
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Updated

7 years ago
Blocks: 816946
No longer blocks: 788977
Priority: -- → P1
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Comment 61

7 years ago
Can this test be disabled while we're working to fix it?  It is failing very often...
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
The interesting part:

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog_chrome.js | Console message: [JavaScript Warning: "ReferenceError: reference to undefined property tests.completed" {file: "chrome://mochitests/content/browser/browser/devtools/commandline/test/helpers.js" line: 292}]
Top-orange; disabled on Windows for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7897d0e37bb9
Whiteboard: [test disabled on Windows][leave open]
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)

Updated

7 years ago
Blocks: 820315

Updated

7 years ago
No longer blocks: 816946
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Joe fixed an issue caused by garbage collection that appears to have fixed this issue. Try runs:
https://tbpl.mozilla.org/?tree=Try&rev=7c76a5fa0934
https://tbpl.mozilla.org/?tree=Try&rev=cf68fe057ceb
Attachment #704522 - Flags: review?(jwalker)
Whiteboard: [test disabled on Windows][leave open] → [has-patch]
Attachment #704522 - Flags: review?(jwalker) → review+
Whiteboard: [has-patch] → [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/eeedf652a1c0
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/eeedf652a1c0
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21

Updated

11 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.