Intermittent browser_cmd_calllog_chrome.js | Test timed out (+ often a leak)

RESOLVED FIXED in Firefox 21

Status

defect
RESOLVED FIXED
7 years ago
Last year

People

(Reporter: emorley, Assigned: miker)

Tracking

({intermittent-failure})

Trunk
Firefox 21
x86
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-browser-chrome on 2012-12-03 02:06:07 PST for push b3b4311176fa

slave: talos-r3-w7-020

https://tbpl.mozilla.org/php/getParsedLog.php?id=17552702&tree=Mozilla-Inbound

{
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog_chrome.js | Console message: [JavaScript Warning: "ReferenceError: reference to undefined property tests.completed" {file: "chrome://mochitests/content/browser/browser/devtools/commandline/test/helpers.js" line: 292}]
++DOMWINDOW == 232 (42EB8860) [serial = 7133] [outer = 38F78F60]
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file e:/builds/moz2_slave/m-in-w32-dbg/build/layout/style/Loader.cpp, line 1936
++DOCSHELL 407FD8F0 == 12 [id = 2698]
++DOMWINDOW == 233 (42EAAE98) [serial = 7134] [outer = 00000000]
++DOMWINDOW == 234 (42E9A338) [serial = 7135] [outer = 42EAAE40]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog_chrome.js | Test timed out
}
https://tbpl.mozilla.org/php/getParsedLog.php?id=17552702&tree=Mozilla-Inbound

Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-browser-chrome on 2012-12-03 02:06:07 PST for push b3b4311176fa

slave: talos-r3-w7-020

{
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/commandline/test/browser_cmd_calllog_chrome.js | Test timed out
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 3761707 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2 instances of AsyncStatement with size 48 bytes each (96 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 2089 instances of AtomImpl with size 24 bytes each (50136 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BackstagePass with size 24 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BodyRule with size 16 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CalculateFrecencyFunction with size 12 bytes
}
Summary: Intermittent browser_cmd_calllog_chrome.js | Test timed out → Intermittent browser_cmd_calllog_chrome.js | Test timed out (+ leak)
Summary: Intermittent browser_cmd_calllog_chrome.js | Test timed out (+ leak) → Intermittent browser_cmd_calllog_chrome.js | Test timed out (+ often a leak)
Can this test be disabled while we're working to fix it?  It is failing very often...
Top-orange; disabled on Windows for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7897d0e37bb9
Whiteboard: [test disabled on Windows][leave open]
Blocks: 820315
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Posted patch Re-enable test (obsolete) — Splinter Review
Re-enable test

Joe fixed an issue caused by garbage collection that appears to have fixed this issue. Try runs:
https://tbpl.mozilla.org/?tree=Try&rev=7c76a5fa0934
https://tbpl.mozilla.org/?tree=Try&rev=cf68fe057ceb
Attachment #704524 - Flags: review?(jwalker)
Whiteboard: [test disabled on Windows][leave open] → [has-patch]
Attachment #704524 - Flags: review?(jwalker) → review+
Whiteboard: [has-patch] → [land-in-fx-team]
Changed dependency
Attachment #704524 - Attachment is obsolete: true
https://hg.mozilla.org/integration/fx-team/rev/8c9108129994
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/8c9108129994
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.