Build Thunderbird with Python 2.7 on Windows build slaves

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
6 years ago
7 months ago

People

(Reporter: gps, Assigned: standard8)

Tracking

Details

(Whiteboard: [buildfaster:p2])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #804873 +++

Frank Wein reported in bug 804865 comment #6 that Thunderbird Windows build slaves are still running 2.6. This XP log even shows references to 2.5: https://tbpl.mozilla.org/php/getParsedLog.php?id=17524773&tree=Thunderbird-Trunk&full=1
Mark, do you know the best person to move this forward?
Flags: needinfo?(mbanner)
(Assignee)

Comment 2

6 years ago
(In reply to Gary Kwong [:gkw, :nth10sd] from comment #1)
> Mark, do you know the best person to move this forward?

This is totally in releng's hands. Really, this should have been done as part of bug 804873 - there's no reason to separate out Firefox & Thunderbird changes :-( (which was one of the reasons for moving to the join infra).
Flags: needinfo?(mbanner)
(In reply to Mark Banner (:standard8) from comment #2)
> (In reply to Gary Kwong [:gkw, :nth10sd] from comment #1)
> > Mark, do you know the best person to move this forward?
> 
> This is totally in releng's hands. Really, this should have been done as
> part of bug 804873 - there's no reason to separate out Firefox & Thunderbird
> changes :-( (which was one of the reasons for moving to the join infra).

Though we *might* need some c-c/ code changes, but I'll deal with them as part of ensuring SeaMonkey is ok -- and get proper review if need be.
(In reply to Gregory Szorc [:gps] from comment #0)
> Frank Wein reported in bug 804865 comment #6 that Thunderbird Windows build
> slaves are still running 2.6. 

This may be the case, but I've already made python 2.7 first in the PATH for Thunderbird and b2g. If those builds are using python 2.6, it's because they're choosing that version explicitly.

> This XP log even shows references to 2.5:
> https://tbpl.mozilla.org/php/getParsedLog.php?id=17524773&tree=Thunderbird-
> Trunk&full=1

Test machines still run python 2.5 because Talos requires it. There's no building going on there though.
Maybe something is wrong with the Python setup? The comm-central configure.in should be more or less in sync with mozilla-central configure.in. See for example https://tbpl.mozilla.org/php/getParsedLog.php?id=17598057&tree=Thunderbird-Trunk&full=1 for what I meant:
TB WINNT 5.2 comm-central build on 2012-12-04 09:23:45 PST for push 1c212e41559a
slave: w64-ix-slave102
[...]
  PATH=C:\mozilla-build\nsis-2.46u;C:\mozilla-build\python27;C:\mozilla-build\buildbotve\scripts;C:\mozilla-build\msys\local\bin;c:\mozilla-build\wget;c:\mozilla-build\7zip;c:\mozilla-build\blat261\full;c:\mozilla-build\python;c:\mozilla-build\svn-win32-1.6.3\bin;c:\mozilla-build\upx203w;c:\mozilla-build\emacs-22.3\bin;c:\mozilla-build\info-zip;c:\mozilla-build\nsis-2.22;c:\mozilla-build\nsis-2.33u;c:\mozilla-build\nsis-2.46u;c:\mozilla-build\wix-351728;c:\mozilla-build\hg;c:\mozilla-build\python\Scripts;c:\mozilla-build\kdiff3;c:\mozilla-build\yasm;.;C:\mozilla-build\msys\local\bin;C:\mozilla-build\msys\mingw\bin;C:\mozilla-build\msys\bin;c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\BIN\amd64;c:\Windows\Microsoft.NET\Framework64\v3.5;c:\Windows\Microsoft.NET\Framework64\v3.5\Microsoft .NET Framework 3.5 (Pre-Release Version);c:\Windows\Microsoft.NET\Framework64\v2.0.50727;c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\VCPackages;c:\Tools\msvs9\Common7\IDE;c:\Tools\msvs9\Common7\Tools;c:\Tools\msvs9\Common7\Tools\bin;c:\Tools\sdks\v7.0\bin\x64;c:\Tools\sdks\v7.0\bin\win64\x64;c:\Tools\sdks\v7.0\bin;c:\windows\System32;c:\windows;c:\windows\System32\Wbem;c:\mozilla-build\moztools-x64\bin;c:\mozilla-build\vim\vim72
[...]
checking for python2.7... no
checking for python2.6... /c/mozilla-build/python/python2.6
(Reporter)

Comment 6

6 years ago
m-c is switching over to Python 2.7 on Monday per previous agreements that this would be enough time to move all builders over.
(Assignee)

Comment 7

6 years ago
Created attachment 698561 [details] [diff] [review]
Port

Ports what was already done in bug 804873 to the Thunderbird config.
Attachment #698561 - Flags: review?(bugspam.Callek)
Attachment #698561 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Updated

6 years ago
Assignee: nobody → mbanner
in production
(Assignee)

Comment 11

6 years ago
This is now fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering

Updated

7 months ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.