If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox crashes when I print a page from my site

RESOLVED DUPLICATE of bug 696640

Status

()

Firefox
Untriaged
--
critical
RESOLVED DUPLICATE of bug 696640
5 years ago
5 years ago

People

(Reporter: Leonid, Unassigned)

Tracking

({crash})

17 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

17.77 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 687781 [details]
printCrashError.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11

Steps to reproduce:

I clicked a File/Print on a page, then OK. 


Actual results:

Firefox crashed


Expected results:

Page should have printed normally, as it happens in IE or Chrome.
This happens even with "print to file" checkbox on, so the problem is printer-independent.
Has been reported to us to happen with Firefox versions 13 & 14, but it happens in the latest version 17.0.1 too.
Happens every time, easily re-producable. 
I have saved the page locally and removed from it all (or most) of the code that did not affect the crash. So, if you open this page(along with CSS included into zip) and print, it should crash. If you remove any of the remaining html/css, the crash goes away. But it is not tied to a specific html/css element, rather to a combination.
Please provide a crash id from about:crashes
- https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

I do not crash with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0 and printing to XPS.

This report could be related to bug 802476
Severity: normal → critical
Keywords: crash

Updated

5 years ago
Flags: needinfo?(lvtrusov)
Keywords: stackwanted
(Reporter)

Comment 2

5 years ago
Sorry, here's the latest id of the crash, which results from html page attached to this bug report:
1306fb75-3a16-4492-8be4-f4b962121203

https://crash-stats.mozilla.com/report/pending/1306fb75-3a16-4492-8be4-f4b962121203
Flags: needinfo?(lvtrusov)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 696640
(Reporter)

Comment 4

5 years ago
Maybe a useful piece of info - if page orientation is changed from portrait to landscape, then printing does not crash. So, this likely has something to do with data exceeding page width and the browser not able to adjust the layout for that or truncate the data beyond the page.

Comment 5

5 years ago
This bug is closed because a duplicate of bug 696640.
You need to log in before you can comment on or make changes to this bug.