Add more information to synced tabs

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: ibarlow, Assigned: sriram)

Tracking

unspecified
Firefox 21
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(1 attachment)

Right now we show titles. It would be very useful if we also displayed favicons and URLs
We can't support favicons until Sync does. We could try to show favicons _if_ we already have the favicon for the URL in our database.
I figured, darnit.

Just showing favicons we already have seems less useful, tbh. We can try it if it isn't too hard, or just try it with URLs for now. Or it might just make sense to park this until we get better sync support.
Posted patch PatchSplinter Review
Remote tabs theme changed as per specs. This removes the divider from the TabsTray too.
Attachment #700639 - Flags: review?(mark.finkle)
Attachment #700639 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/3c5a508fc879
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 700639 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Beautiful remote-tabs list will be missed.
Testing completed (on m-c, etc.): Landed in m-c on 01/12.
Risk to taking this patch (and alternatives if risky): Very low. The layout styles are changed.
String or UUID changes made by this patch: None.
Attachment #700639 - Flags: approval-mozilla-aurora?
Comment on attachment 700639 [details] [diff] [review]
Patch

Approving patches needed for Bug 817675 , considering all these are needed for private browsing feature landing in FF20 .
Attachment #700639 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
-build: Firefox for Android 20.0a2 (2013-02-15), Firefox for Android 21.0a1 (2013-02-15)
-device: Samsung Galaxy Tab 2 7.0
-OS: Android 4.0.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.