If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[meta] Tab tray refinements on Firefox for Android

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: ibarlow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
This is the meta bug for the latest set of tab refinements on Firefox for Android. Enhancements include but are not limited to:

General
* Create unique sections for normal, private, and synced tabs
* Add ability to close all open tabs
* Add ability to undo closed tabs

Tablets
* Placing tabs on top in portrait view
* Allowing tab sidebar to be pinned open in landscape view
* Applying the large tablet UI to smaller tablets like the Nexus 7

Phones
* Different tab UIs for portrait and landscape views
(Reporter)

Comment 1

5 years ago
Created attachment 687857 [details]
Overview of tab changes

These mockups are still fairly low fidelity, but should suffice for roughing in the structure and interaction we're after. 

Once that's done we can do a visual polish pass.
(Reporter)

Updated

5 years ago
Depends on: 817706
(Reporter)

Updated

5 years ago
Depends on: 817716
(Reporter)

Updated

5 years ago
Depends on: 817721
(Reporter)

Updated

5 years ago
Depends on: 817728
(Reporter)

Updated

5 years ago
Depends on: 817732
(Reporter)

Updated

5 years ago
Depends on: 817735
(Reporter)

Updated

5 years ago
Depends on: 817739
(Reporter)

Updated

5 years ago
Depends on: 817749
Depends on: 701725

Updated

5 years ago
Blocks: 814137
(Reporter)

Updated

5 years ago
Depends on: 818124
Depends on: 818229

Updated

5 years ago
Depends on: 818438
(Reporter)

Updated

5 years ago
Depends on: 718434
Depends on: 824469

Updated

5 years ago
Depends on: 824501
(Reporter)

Comment 2

5 years ago
Created attachment 697580 [details]
Overall visual design mockup

Posting these to this meta bug, since these designs touch a number of bugs in progress here.
(Reporter)

Comment 3

5 years ago
Created attachment 697581 [details]
A more detailed look at tab menu elements (thumbnails, tabs, spinners)

Updated

5 years ago
Depends on: 826310
Depends on: 826820
No longer depends on: 826310
(Reporter)

Updated

5 years ago
Depends on: 828329
(Reporter)

Updated

5 years ago
Depends on: 830756
(Reporter)

Updated

5 years ago
Depends on: 830758
(Reporter)

Updated

5 years ago
Depends on: 830761
(Reporter)

Updated

5 years ago
No longer depends on: 830761
(Reporter)

Updated

5 years ago
No longer depends on: 830758
(Reporter)

Updated

5 years ago
No longer depends on: 830756
Depends on: 831402
Depends on: 832433
Depends on: 833471
(Reporter)

Updated

5 years ago
Depends on: 834332
Depends on: 834525
Depends on: 833812
Depends on: 836043
Depends on: 834399
(Reporter)

Updated

5 years ago
Depends on: 838735
(Reporter)

Updated

5 years ago
Depends on: 838748
Depends on: 838807
(Reporter)

Updated

5 years ago
Depends on: 842621
(Reporter)

Updated

5 years ago
Depends on: 843641

Updated

5 years ago
Blocks: 857950

Updated

5 years ago
No longer blocks: 857950
Depends on: 857950
(Reporter)

Updated

5 years ago
Depends on: 862996
(Reporter)

Updated

5 years ago
Depends on: 863379
Depends on: 867566

Updated

3 years ago
Depends on: 1003782

Updated

3 years ago
Duplicate of this bug: 1148521
Summary: [meta] Tab refinements on Firefox for Android → [meta] Tab tray refinements on Firefox for Android

Updated

2 years ago
No longer depends on: 818124

Updated

2 years ago
No longer depends on: 718434

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.