Closed Bug 817790 Opened 7 years ago Closed 7 years ago

Stretched Facebook icon briefly shows over entire toolbar during window startup

Categories

(Firefox Graveyard :: SocialAPI, defect)

19 Branch
defect
Not set

Tracking

(firefox19+ verified, firefox20+ verified)

VERIFIED FIXED
Firefox 20
Tracking Status
firefox19 + verified
firefox20 + verified

People

(Reporter: Felipe, Assigned: markh)

References

Details

(Keywords: regression)

Attachments

(1 file)

When open a new window, the entire Toolbar.png set shows briefly stretched over the entire toolbar. Then the provider icon itself shows with the same problem, and after a moment the toolbar icons are properly sizes.
properly *sized
The only Social API change I see that touched UI code is bug 813436 (contained in the Nov 27 PGO merge):
http://hg.mozilla.org/mozilla-central/rev/532d0832c09d
Of the social bugs in that set, I assume bug 813436 is the most likely culprit?
I can see this in rev 62bb8cc3277b, which is before those social changes landed.  I'll try and narrow it further
(In reply to Mark Hammond (:markh) from comment #5)
> I can see this in rev 62bb8cc3277b, which is before those social changes
> landed.  I'll try and narrow it further

I screwed up my testing -  bug 813436 is the culprit.
Assignee: nobody → mhammond
Depends on: 813436
The problem is that we are updating the broadcaster's hidden attribute before we've set the correct provider image.  This patch shifts the broadcaster update to after the toolbar has been initialized.
Attachment #688090 - Flags: review?(jaws)
Comment on attachment 688090 [details] [diff] [review]
set hidden after toolbar init

Review of attachment 688090 [details] [diff] [review]:
-----------------------------------------------------------------

Cool, LGTM.
Attachment #688090 - Flags: review?(jaws) → review+
Status: NEW → ASSIGNED
Version: unspecified → 19 Branch
Blocks: 813436
No longer depends on: 813436
https://hg.mozilla.org/mozilla-central/rev/9ce29406488e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
Triage drive-by: please nominate for Aurora when you can.
Comment on attachment 688090 [details] [diff] [review]
set hidden after toolbar init

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 813436
User impact if declined: Ugly toolbar "flash" when new windows opened.
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): Low risk, only social code impacted.
String or UUID changes made by this patch: None
Attachment #688090 - Flags: approval-mozilla-aurora?
Attachment #688090 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Verified as fixed on Firefox 19 RC - during window startup, the stretched Facebook icon isn't shown over the toolbar.  

Verified as fixed on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Build ID: 20130215130331 
Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0

Verified for Firefox 20 beta 6. Windows 7, Ubuntu 12.04. No display issues when using a new window with facebook social enabled.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.