Closed Bug 818072 Opened 7 years ago Closed 7 years ago

PBM - Back and forward button enabled / disabled states look reversed

Categories

(Firefox for Android :: General, defect, P1)

20 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 21
Tracking Status
firefox20 --- verified
firefox21 --- verified
fennec 20+ ---

People

(Reporter: ibarlow, Assigned: sriram)

References

Details

Attachments

(1 file, 1 obsolete file)

When private browsing on tablets, the back and forward buttons look disabled when they are enabled, and vice versa. 

It is possible that this issue will be fixed with bug 818071, but I want to track this as a separate bug, just in case we need to do additional work here to fix it.
Assignee: nobody → sriram
tracking-fennec: --- → 20+
Priority: -- → P1
Was about to file this, yeah the state looks reversed. Tested on my Nexus 7 this morning.
OS: Mac OS X → Android
Hardware: x86 → ARM
Version: unspecified → Firefox 20
Blocks: pb
We use a filter of #999999 over the disabled icons. Do we use a different color for the private browsing mode? If so what color?
Ian can you answer Sriram's question?
Flags: needinfo?(ibarlow)
Sriram, you can use #333333 as your overlay colour. 

Alternately, you can make disabled icons 30% transparent
Flags: needinfo?(ibarlow)
Attached patch Patch (obsolete) — Splinter Review
Saved the back button! We are looking soooo gooood!
Attachment #711519 - Flags: review?(mark.finkle)
Attached patch PatchSplinter Review
Added a null check.
Attachment #711519 - Attachment is obsolete: true
Attachment #711519 - Flags: review?(mark.finkle)
Attachment #711525 - Flags: review?(mark.finkle)
Attachment #711525 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/46d7188acb0c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 711525 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Old code that applies a filter.
User impact if declined: A white filter over black url-bar.
Testing completed (on m-c, etc.): Landed in m-c on 02/08.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #711525 - Flags: approval-mozilla-aurora?
Keywords: verifyme
QA Contact: aaron.train
Comment on attachment 711525 [details] [diff] [review]
Patch

low risk fix, approving on aurora.

Request to QA to help with testing/verification here .
Attachment #711525 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.