Closed Bug 818079 Opened 10 years ago Closed 9 years ago

Tab menu overlaps URL bar

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox19 unaffected, firefox20+ verified, firefox21+ verified, firefox22+ verified, fennec20+)

VERIFIED FIXED
Firefox 22
Tracking Status
firefox19 --- unaffected
firefox20 + verified
firefox21 + verified
firefox22 + verified
fennec 20+ ---

People

(Reporter: aaronmt, Assigned: lucasr)

References

Details

(Keywords: regression)

Attachments

(2 files)

This must be a recent regression (12/03-12/04). See screenshot.

--
Nightly (12/04)
Samsung Galaxy Nexus (Android 4.1.2)
Assignee: nobody → sriram
Probably caused by bug 709433. Steps to reproduce?
Assignee: sriram → lucasr.at.mozilla
This is probably the same as bug 817526. Closing as dup.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817526
This is still not fixed (sorry for the delay, noticed via Kats dupe today).

Steps to reproduce in Kats's bug.
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
Resolution: DUPLICATE → ---
Duplicate of this bug: 830356
Status: REOPENED → ASSIGNED
The regression window for this issue:

good build: 03.12.2012  
bad build:  04.12.2012 

possible pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=253009438c5b&tochange=6fa6e55a93b2
Yep, was the animation bug 709433
Firefox 19 is unaffected. LucasR we have a very short period of time to take a fix for this. Would it be possible to back out bug 709433 if we are unsure of the fix here?
Flags: needinfo?(lucasr.at.mozilla)
What are the steps to reproduce?
Flags: needinfo?(lucasr.at.mozilla)
Keywords: qawanted
(In reply to Lucas Rocha (:lucasr) from comment #8)
> What are the steps to reproduce?

Looks like Kats has STR in bug 830356 (a dupe of this bug)
tracking-fennec: ? → 20+
Double tap in the address bar from any page.
Keywords: qawanted
(In reply to Kevin Brosnan [:kbrosnan] from comment #10)
> Double tap in the address bar from any page.

Investigating.
Duplicate of this bug: 850764
Because the animation logic relies on updating the layout of the toolbar before and after the actual animation, there's no simple way to allow "reversing" the animation while it's running.

We might be able to do reverse the animation properly once we simplify the animation code as part of bug 848719. But that's likely a more involved patch.
Attachment #724513 - Flags: review?(mark.finkle)
Comment on attachment 724513 [details] [diff] [review]
Don't allow entering awesomescreen while animating

Hmm, I assumed there would be less places to set the mAnimatingEntry state
Attachment #724513 - Flags: review?(mark.finkle) → review+
(In reply to Mark Finkle (:mfinkle) from comment #14)
> Comment on attachment 724513 [details] [diff] [review]
> Don't allow entering awesomescreen while animating
> 
> Hmm, I assumed there would be less places to set the mAnimatingEntry state

mAnimatingEntry needs to be set on the animations to/from awesome screen. And when we (re-)init the toolbar.
Comment on attachment 724513 [details] [diff] [review]
Don't allow entering awesomescreen while animating

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 709433
User impact if declined: Broken toolbar layout on certain situations
Testing completed (on m-c, etc.): Local testing, waiting for it to land in m-c. Request approval early given the urgency for the beta release.
Risk to taking this patch (and alternatives if risky): Very low, just avoiding triggering the toolbar animation while it's already running.
String or UUID changes made by this patch: n/a
Attachment #724513 - Flags: approval-mozilla-beta?
Attachment #724513 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b65eb98101d5
Status: ASSIGNED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 724513 [details] [diff] [review]
Don't allow entering awesomescreen while animating

low risk uplift for a FX20 regression.

Adding qawanted/verifyme to help with verification here.
Attachment #724513 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #724513 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: RESOLVED → VERIFIED
Keywords: qawanted, verifyme
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.