Closed Bug 818162 Opened 9 years ago Closed 9 years ago

TED talk video does not start

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jbecerra, Unassigned)

References

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20121203 Firefox/20.0
Click-to-Play is set to true.

When you try to play a TED talk video when your preferences have click-to-play enabled, and you try to play any video the video, it never starts playing. It just stays at "Optimizing Video Quality"

Steps:
1. With a Nightly and click-to-play go to https://www.ted.com/talks and try to play video
2. Click on the "Click to Play" area once the page loads

Expected: Your plugin loads and starts playing after a brief while.

Actual: It seems to load the plugin but it stalls at "Optimizing Video Quality"

Reproducible: Always, although this is a crufty profile.

I tried this on Fx18b2 and it worked in both modes, whether click-to-play was enabled or not.
Keywords: qawanted
Works for me with the current nightly (2012-12-04) and Flash 11.5.502.110
I've certainly had ted talks work for me, e.g. 

* load http://www.ted.com/talks/sarah_jayne_blakemore_the_mysterious_workings_of_the_adolescent_brain.html
* click to play the plugin
* it works

Using Nightly.
Juan, are you sure it's not working only with CTP enabled?
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=810638
Anyway, I cannot reproduce both with CTP on/off on Nightly 20.0a1 (2012-12-04) on Win 7, Mac OS X 10.7.
Fx18: worked with CTP enabled or disabled.
Fx20: Did not work.

It turned out to be an add-on, HTTPS Everywhere. Disabling it made the video work in Nightly.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
Duplicate of this bug: 810638
You need to log in before you can comment on or make changes to this bug.