Closed Bug 818351 Opened 7 years ago Closed 7 years ago

B2G Multi-SIM: telephony - add subscriptionId in nsITelephonyProvider & nsITelephonyListener

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 814625

People

(Reporter: hsinyi, Assigned: hsinyi)

References

Details

Attachments

(1 file)

This bug was originally reported in Bug 814584. This bug focuses on re-factoring 'telephony' related functions and messages. 

What we probably need to do is:
a) nsIRILContentHelper IDL change: add an attribute 'subscriptionId'
b) DOM changes: assign '0' (default subscriptionId) in every RILContentHelper function call based on a)
c) RIL impl: i) add a property 'subscriptionId' in IPC messages ii) deliver callback to a specific subscriptionId ...
Blocks: 814584
Assignee: nobody → htsai
Attached file Working branch
Working branch -- need to rebase on Bug 814581
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> Created attachment 688690 [details]
> Working branch
> 
> Working branch -- need to rebase on Bug 814581

Updated: already rebased on Bug 814581
Summary: B2G Multi-SIM: telephony - add subscriptionId in nsIRILContentHelper → B2G Multi-SIM: telephony - add subscriptionId in nsITelephonyProvider & nsITelephonyListener
Depends on: 921422
Has been addressed in bug 814625.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 814625
No longer blocks: 814584
You need to log in before you can comment on or make changes to this bug.