Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Bookmarks toolbar items not populated if grippy is collapsed when the browser window is opened

RESOLVED FIXED in seamonkey2.19

Status

SeaMonkey
UI Design
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: R.G.Belleman, Assigned: Philip Chee)

Tracking

SeaMonkey 2.14 Branch
seamonkey2.19
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14
Build ID: 20121118021014

Steps to reproduce:

1. Make sure the "Bookmarks Toolbar" is visible and has items in it
2. Minimize the toolbar with the little triangle button at far left
3. Open a new browser window (e.g. Ctrl-N)
4. De-minimize the toolbar with the little triangle button at far left


Actual results:

The "Bookmarks Toolbar" items do not show.

Having done the previous steps, again open a new browser window:
this time the "Bookmarks Toolbar" items /do/ show.


Expected results:

The "Bookmarks Toolbar" items should always show when the toolbar is not minimized.

Comment 1

5 years ago
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Duplicate of this bug: 851081
(Assignee)

Updated

4 years ago
Summary: Bookmarks toolbar items not updated after minimization → Bookmarks toolbar items not populated if grippy is collapsed when the browser window is opened
(Assignee)

Comment 3

4 years ago
Created attachment 725771 [details] [diff] [review]
Patch v1.0 Proposed fix.

Ignore hidden/collapsed state of the bookmarks toolbar when running PlacesToolbarHelper.init().
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #725771 - Flags: review?(neil)

Updated

4 years ago
Attachment #725771 - Attachment is patch: true
Attachment #725771 - Flags: review?(neil) → review+
(Assignee)

Comment 4

4 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/57f97b40a8d1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.19
You need to log in before you can comment on or make changes to this bug.