Note: There are a few cases of duplicates in user autocompletion which are being worked on.

'http' missing from address bar, status bar

RESOLVED DUPLICATE of bug 667178

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 667178
5 years ago
4 years ago

People

(Reporter: HyperHacker, Unassigned)

Tracking

17 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121120042814

Steps to reproduce:

Open any web page, or hover over any URL, that uses http:// protocol. Especially, try to copy the URL from the address bar.


Actual results:

The protocol string is not shown, and not included in the URL when copied. It makes the status bar a bit strange at times ("what is this text in the corner?") and makes copying URLs to share quite a pain the backside.


Expected results:

Protocol string should be shown and included in copied URLs.

Comment 1

5 years ago
Set about:config > browser.urlbar.trimURLs = false. Does it work for you?

Updated

5 years ago
Flags: needinfo?(hyperhacker)
(Reporter)

Comment 2

5 years ago
That seems to do it. I wonder why this option exists, and especially is enabled by default?
Flags: needinfo?(hyperhacker)

Comment 3

5 years ago
Trimmed URLs is an old feature introduced into Firefox 7. But some issues persist (with copy/paste e.g. like bug 697248).
(Reporter)

Comment 4

5 years ago
Seems more like a misfeature... why decide to start hiding part of the URL? Perhaps the bug is not in the code, but in its intent.
This works for me, even if the setting from comment 1 is set to true: browser.urlbar.trimURLs = true, while testing on the latest Nightly.

User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121210 Firefox/20.0
Build ID: 20121210030747

Updated

4 years ago
Blocks: 665580

Updated

4 years ago
No longer blocks: 665580
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 667178
You need to log in before you can comment on or make changes to this bug.