Closed Bug 818569 Opened 7 years ago Closed 7 years ago

When installing new gecko, we should stop B2G first

Categories

(Testing :: Marionette, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox19 fixed, firefox20 fixed, b2g18 fixed)

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- fixed
firefox20 --- fixed
b2g18 --- fixed

People

(Reporter: jgriffin, Assigned: jgriffin)

Details

Attachments

(1 file, 1 obsolete file)

According to cjones, some of the b2g process crashes in our logs occur because we are copying a new gecko before shutting B2G down.  We should try changing this and see what happens.

The problem is that when any test fails for any reason, it looks in the log like it's caused by the B2G process crash, even though that crash happened during installing of a new gecko and has nothing to do with the test run.  E.g., https://tbpl.mozilla.org/php/getParsedLog.php?id=17628314&tree=Mozilla-Inbound, which got starred as bug 814551, even though it's a completely separate failure.

One problem with shutting down B2G before copying the files is that it may make our intermittent 'hang while adb pushing' bug more frequent; we'll have to see if that turns out to be a problem.
Assignee: nobody → jgriffin
On the only job that's finished (R2), this did indeed trigger the adb-push hang.  Our code recovered from it, but if this happens too often we'll get buildbot timeouts.  On the positive side, there aren't any crashes in the log.

I'll try a tweaked version of this.
Attachment #688851 - Attachment is obsolete: true
(In reply to Jonathan Griffin (:jgriffin) from comment #3)
> take 2: https://tbpl.mozilla.org/?tree=Try&rev=522bfaeb19ec

also https://tbpl.mozilla.org/?tree=Cedar&noignore=1&rev=edfd3cedd1a6, since I think cedar has shorter turnaround times than try
I backed this out of cedar since it seems to consistently break the Mn tests and I was worried it might also be affecting the xpcshell tests:
https://hg.mozilla.org/projects/cedar/rev/4f5570fee38
That's really weird.  Unfortunately, I cannot reproduce this locally.
I still can't reproduce this.  I'm going to file a bug for an emulator refresh to see if that fixes things.
Pushed to try again since we have a new emulator: https://tbpl.mozilla.org/?tree=Try&rev=4e4301a88d29
(In reply to Jonathan Griffin (:jgriffin) from comment #8)
> Pushed to try again since we have a new emulator:
> https://tbpl.mozilla.org/?tree=Try&rev=4e4301a88d29

This was all green except for xpcshell; I've pushed to try again to see if it's consistent:

https://tbpl.mozilla.org/?tree=Try&rev=fe7f6ca531c2
(In reply to Jonathan Griffin (:jgriffin) from comment #9)
> (In reply to Jonathan Griffin (:jgriffin) from comment #8)
> > Pushed to try again since we have a new emulator:
> > https://tbpl.mozilla.org/?tree=Try&rev=4e4301a88d29
> 
> This was all green except for xpcshell; I've pushed to try again to see if
> it's consistent:
> 
> https://tbpl.mozilla.org/?tree=Try&rev=fe7f6ca531c2

Same result; this appears to cause xpcshell update tests to fail, which makes no sense to me.  Any ideas why this might happen, Andrew?
Those tests require a special binary that gets built and added when --enable-updater is added to the mozconfig. Is it possible that this binary exists, then we rmDir /system/b2g and fail to copy it back?

Additionally the subset of tests that are included in xpcshell_updater.ini also require a TestAUSHelper binary (see bug 821343)
WIP.  Ugh, I had a stupid mistake that was causing us not to copy any files at all.  I'm glad xpcshell complained
(In reply to Jonathan Griffin (:jgriffin) from comment #13)
> pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=33db0aa82f14

xpcshell tests are green now. The others haven't shown up yet, so still waiting...
Comment on attachment 693627 [details] [diff] [review]
Stop B2G before updating gecko

Review of attachment 693627 [details] [diff] [review]:
-----------------------------------------------------------------

Try run was green this time.
Attachment #693627 - Flags: review?(ahalberstadt)
Comment on attachment 693627 [details] [diff] [review]
Stop B2G before updating gecko

Review of attachment 693627 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #693627 - Flags: review?(ahalberstadt) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/21c0b3fbad22
Whiteboard: [automation-needed-in-aurora][automation-needed-in-b2g18]
Target Milestone: --- → mozilla20
https://hg.mozilla.org/mozilla-central/rev/21c0b3fbad22
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.